2
  • I had a backup on my hard-drive which I wanted to delete (300GB), so I moved to the trash.
  • Deleting most files seemed to be okay, however, it then got to the applications folder and other system related stuff. This took forever and kept freezing my macbook, which I needed for work.
  • Numerous times I force restarted my laptop with the HD still connected, and one time I had to remove the HD because it was again freezing everything (all whilst removing the trash from the HD).
  • The last time I was able to load the HD there was over 100GB to still delete.
  • Now, when I connect the HD the light is blinking but not loading on my mac. I checked other advice which was to use the diskutil list.
  • When I tried diskutil mount it didn't work and kicked me out.

I suspect the drive is repairing or working out something, and eventually it will load. But any advice would be appreciated. Have so much work saved on there.

I also tried loading disk utility but it just renders and nothing actually loads.

TIA

output of diskutil

6
  • What macOS are you on? Was this a Time Machine backup? Golden Rule: Don't throw Time Machine backups in the Trash… :\
    – Tetsujin
    Sep 8, 2021 at 11:48
  • macOSBig Sur, and yes it was a time machine backup. It was one from an old mac and I couldn't remove files I didn't need. I managed to put in the trash, violating the golden rule (that I didn't know about).
    – GIS_newbie
    Sep 8, 2021 at 11:59
  • tbh, I'm not sure how you get out of this one. Big Sur doesn't use Hard Links, yet that's what prior Time Machine drives depended on. Deleting TM from Trash also required disabling SIP. I really don't have enough experience with Big Sur to know how to handle this… but there are several very smart cookies on this site, so I sincerely hope one of them can help you. Good Luck.
    – Tetsujin
    Sep 8, 2021 at 12:05
  • So this is the only copy? What about the original if this drive is the backup?
    – Solar Mike
    Sep 8, 2021 at 21:21
  • so the drive had 300GB which was a previous back up from an old macbook, and also 700GB of new data stored. I managed to load it in Disk Utility and tried first aid, but nothing materialised. I tried ejecting and un-mounting and re mounting via terminal but nothing. Disk Drill picked up the HD but had problems scanning it. So it is connecting, just not opening.
    – GIS_newbie
    Sep 8, 2021 at 23:22

1 Answer 1

-1

If the drive shows up in Terminal, you could try to erase it from there.

diskutil eraseDisk jhfs+ Untitled /dev/disk2
2
  • I very much doubt the OP wants to erase the entire drive. "Have so much work saved on there."
    – Tetsujin
    Sep 8, 2021 at 13:59
  • thank you, yes, I have 1TB of data on the HD so I don't want to erase
    – GIS_newbie
    Sep 8, 2021 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .