2

So I arrived home from school today and wanted to use my iMac, but somehow it wouldn't react. I pressed the power button until it shut down (or crashed...) and rebooted it. After rebooting everything seemed normal, but there was this error, that the keychain login couldn't be accessed. After googling and seeing, that the login keychain was missing in "Keychain Access", I decided to restore my Time Machine Backup from the evening before. After TM failed the first attempt (Shut down at 20%) I tried again, but somehow everything got fucked up.

I don't remember 100% exactly how everything happened, but the end result now is, that I do not see the HDD of my Fusion Drive CoreStorage. The SSD is visible in Disk Utility, but not the HDD. It also is not shown in "diskutil list" and not shown in Parted Magic. I also tried booting while holding the "D" key to enter Apple Hardware Test, but the result was, that everything is okay...

I'm really desperate right now, because I didn't had a very good mood when I came home and now the day is totally trash. I really appreciate every bit of help or information, that could help me..

If you have questions, don't hesitate to ask.

EDIT: - I tried to reset the SMC (unplug the iMac from power for 15 seconds) and it changed nothing.

The terminal outputs of diskutil list,diskutil cs list, gpt -r show disk0/disk1:

-bash-3.2# diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *1.2 GB     disk1
   1:        Apple_partition_map                         30.7 KB    disk1s1
   2:                  Apple_HFS Mac OS X Base System    1.2 GB     disk1s2
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk2
   ....

-bash-3.2# diskutil cs list
No CoreStorage logical volume groups found
-bash-3.2# gpt -r show disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34  236978109        
  236978143         32         Sec GPT table
  236978175          1         Sec GPT header

-bash-3.2# gpt -r show disk1
    start     size  index  contents
        0  2330500
  • Please add the output of diskutil cs list, gpt -r show disk0 and gpt -r show disk1 entered in Terminal.app booted to recovery mode (or another external boot drive). – klanomath Jun 23 '16 at 22:21
  • I uploaded them to pastebin: link – iComputerfreak Jun 23 '16 at 22:30
1

The SSD is disk0, the internal HDD (which should be disk1 if a Fusion disk is attached) is missing. Instead your recovery volume (loaded from Apple) is disk1.

Your internal HDD probably either died or the SATA cable is loose/broken. You have to replace the HDD and/or the cable.

The SSD seems to be functional but misses any partition. It already contains a GUID partition table though.

If the size of the backup data is smaller than ~118 GB (which is unlikely) you should be able to restore it after adding a partition. Otherwise you have to replace the HDD part of the Fusion disk and restore the backup later.

A temporary work-around is to restore OS X after adding a partition in Internet Recovery Mode, updating to your current OS X and then use the Migration Assistant to only import the most important data.

  • Okay. I already feared this. So I will go to the Apple Store on Tuesday and hope they can help me... The backup is larger than 120 GB and setting up a new system until Tuesday is too much stress for me but thanks for your advice. – iComputerfreak Jun 23 '16 at 23:51
  • I was at the Apple Store today and they keep my mac to replace the hard drive for free, like they did a year ago when I had a similar problem. – iComputerfreak Jun 29 '16 at 9:33
1

I think it's time to start thinking about data recovery at this point. Half-performing Time-Machine can mess things up pretty badly (you don't need to be being told this, you're living it).

This is most easily done (read: Unless you want to open it, which isn't terrible, but definitely not for a novice) by holding the "T" button on the keyboard while powering up. This basically is like opening up your Mac, removing the internal drive, placing it in an enclosure, and then connecting it to another Mac. But it does all of that without any disassembly.

Before entering Target Disk Mode, you’ll need a few things:

  • Two Macs: Target Disk Mode works with Macs, so you’ll need two Macs for this. Each Mac needs either a Thunderbolt port or a Firewire port. [You might need to borrow a friends' if you don't have one]
  • A Firewire or Thunderbolt Cable: You’ll need either a Firewire cable or a Thunderbolt cable for this. You can’t do this via a USB cable. If one Mac has a Thunderbolt port and the other Mac has a Firewire port, you’ll need a Thunderbolt-to-Firewire adapter cable.
  • FileVault Disabled: Macs now enable FileVault encryption by default, which will prevent you from accessing FileVault-encrypted home directories over Target Disk Mode. Before using Target Disk Mode, you can boot the Mac normally, open the System Preferences window, select Security & Privacy, select FileVault, and temporarily turn it off. You can turn it on again after using Target Disk Mode. [You can't do this step, so we'll just hope it was off...]
  • No Firmware Password: If you’ve set a firmware password in the recovery environment, you’ll need to disable that first. [If this makes no sense, you probably don't have one]

With Target Disk Mode, you can treat a Mac’s internal drive as an external drive and boot from it, just as you’d boot from a typical external drive. This actually lets you boot the OS X system from one Mac on another Mac.

You can also simply plug it into another Mac, and download your important files. Once this is done, we will want to reinstall Mac OSX onto the iMac.

To Re-install OSX once your files are safe and sound:

Immediately after hearing the Mac boot chime, hold down Command+Option+R – if you see the Apple logo you waited too long and need to reboot and try again* OPTIONAL: You may or may not see an option to join a wi-fi network, this depends on whether the Mac can access any saved networks from OS X or not When you see a spinning globe icon, Internet Recovery mode has been entered with a message saying it can take a while, a progress bar appears as the recovery functions are downloaded Starting OS X Internet Recovery Mode on a Mac to reinstall system software.

When finished downloading, you’ll see the familiar “OS X Utilities” screen, choose “Reinstall OS X” to begin the re-installation process of the Mac operating system Install OS X from Internet Recovery.

Select the destination and complete the re-installation (or installation) of OS X as usual.

Sources [First Half, Second Half].

  • FileVault is not enabled by default and in newer systems (10.7 - ...) there is no FV-encrypted home directory anymore! – klanomath Jun 23 '16 at 22:08
  • Sorry I think you understood me wrong or may I didn't explain it very well. I already have a full TimeMachine Backup of my PC on an external drive which is fully operable. The problem is my internal hard drive on which my OS was. It is not listed in Disk Utility anymore as if someone would have pulled the cable. And it is also not shown in Ubuntu when I boot from an USB Stick, so I don't think it has something to do with the system. My problem is reinstalling OS X, because I don't see a disk, where I can install it... I will try adding a few logs to my post to make this more clear... – iComputerfreak Jun 23 '16 at 22:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .