1

I've numbered each point – as there are a lot – in the hope it makes it easier to reply or ask me for further info. Thanks!

  1. The Problem
  2. What I've Tried So Far...
  3. Next Steps?
  4. Screenshots

The Problem

  1. 2018 MBP Will not boot using Internet Recovery, nor any other type of Recovery thus far.
  2. Get variety of errors - 1008f, 2300f, 2100f.
  3. 2018 MBP is running Big Sur (possibly a recent beta version, icr)
  4. Have updated 2011 iMac to High Sierra 10.13.6. It's moving slowly, but it's definitely moving. It's a 3.4 GHz Intel Core i7, 8 GB 1333 MHz DDR3, plenty of free disk space - 1.76TB.
  5. I have most important stuff on the MBP backed up, but concerned due to medical reasons that vital things may not have been backed up in recent times - my eye has been off the ball somewhat...
  6. I really want to access the Data on the MBP if I possibly can.
  7. I fear the Logic Board might be on it's way, but hope I can salvage something.

What I've Tried Already

  1. Updated iMac to HS, to create bootable installer of High Sierra using Terminal commands. It's Extended Volume, not AFPS. Can make another in AFPS if it will remotely help.
  2. MBP did not boot to it. Still brings up Network prompt which ultimately seems to cause the fail each time.
  3. MBP appears to process connecting the MBP to WiFi Network each time, but then produces variety of error codes at the end, even when using bootable installer and Option key. 12 Have even put entire High Sierra OS on external drive, endeavouring to effectively use external drive as a Mac Mini with ailing MBP just the screen. Nope. Still wants to connect to to Network (this is for the Firmware, afaik?)
  4. Have today connected MBP to iMac using Thunderbolt 3 cable and USB-C to Thunderbolt adaptor.
  5. Endeavouring to boot using Target Disk Mode.
  6. Can see MBP Macintosh HD - Data in Disk Utility, but cannot perform First Aid, nor Mount it. IMAGE BELOW
  7. Also have a Drive titled Update in externals, which seems to show the Data and ?(Big Sur beta update?) maybe? (I haven't called it Update, and I'm not quite sure what it is) IMAGE BELOW
  8. Tried Terminal commands to Verify Data, getting a variety of Permission Denied errors. IMAGE BELOW
  9. Tried \\ diskutil verifyDisk disk2 \\ which gives: Unable to verify this whole disk: A GUID Partition Table (GPT) partitioning scheme is required (-69773)
  10. Tried \\ diskutil verifyDisk disk2s1 \\ (that's the volume(?) with the data on) which gives: "A whole disk must be specified"
  11. <mutters 'make your bloody mind up...'>
  12. Downloaded iBoysoft to try and recover data.
  13. It can see the Data, but there's a padlock on the Drive and it's asking: "Please enter the password of your encrypted APFS partition" IMAGE BELOW
  14. Wondering if this is a FireVault thing? I'm not sure if it's switched on, on the MBP or not. If it is, I have absolutely no idea what the encrypted partition password is, nor where I'd find such information.
  15. Apparently, I can run iBoysoft Data Recovery in macOS Recovery mode.
  16. I'm not sure if this will be complicated because I am also using Target Disk Mode, rather than running iBoysoft directly on the affected MBP, because I can't. A search of the iBoysoft FAQs fails to offer an answer to this query.

Next Steps

  1. Is there any point in creating another Bootable Installer, this time as APFS, rather than Extended Volume?
  2. Where can I find the encrypted APFS password info? (I'm not convinced I have one, but it may have switched on by default?) I am a devil for recording passwords so if I was aware this existed, I absolutely would have made a note of it. What would it look like format-wise?
  3. And where would I enter it for the Disk Utility or Terminal to be able to access 'MBP Macintosh HD - Data'?
  4. Would entering the command prompt \\ sudo Fsck_APFS /dev/disk2s1 \\ do anything helpful?
  5. I have a 2019 MBP running Big Sur which thoughtfully simultaneously fell over. This happened while I was awaiting delivery of the super-fast Thunderbolt 3 cable to do the data transfer. It has refused to switch on since, so I am pretty much stuck with the 2011 iMac as rescuer for now. (And yes, I've tried all the usual suspects NVRAM, SMC on the dead second MBP etc)

I am an absolute novice at all of this, so please speak ** s l o w l y ** to me in simple terms. This is my first post and I'm doing my best...

Screenshots

Update disk is mounted, but Macintosh HD - Data from MBP is unmounted and I cannot mount it

Macintosh HD - Data from MBP is unmounted and I cannot mount it

First Aid didn't work on the MBP Macintosh HD - Data

Terminal distil repairVolume failed due to Permissions

APFS Volume Data

The specific Volume I need to access

What iBoysoft is asking for, and mention of Recovery - see #27

1 Answer 1

0

You should be booting your 2018 MBP from the current version of the Big Sur installer. Currently this is macOS 11.4. To make the USB bootable installer you need the Install macOS Big Sur application. Using my iMac (21.5-inch, Mid 2011) with macOS High Sierra Version 10.13.6 installed, I created this installer by using the following steps.

  1. Download the InstallAssistant.pkg directly from Apple. I used the Apple URL http://swcdn.apple.com/content/downloads/55/59/071-00696-A_4T69TQR1VO/9psvjmwyjlucyg708cqjeaiylrvb0xph94/InstallAssistant.pkg

  2. Use the Finder application to open the InstallAssistant.pkg with the Installer application.

  3. Proceed to install the InstallAssistant. This will create the Install macOS Big Sur application in the Applications folder

  4. Use the Disk Utility application to erase a 16 GB USB-A 3.0 flash drive. Choose the following settings.

  5. Execute the following command in a Terminal application window. The will create the bootable Big Sur USB-A flash drive installer.

    sudo /Applications/Install\ macOS\ Big\ Sur.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume
    

Note: To plug the flash drive into a 2018 MBP would require the proper USB-C to USB-A Adaptor. For example, this adaptor from Belkin.

References

macOS Big Sur Full Installer Database. Download Directly from Apple!
How to create a bootable installer for macOS
3.0 USB-C to USB-A Adapter (USB-C Adapter)

1
  • Thank you, David Sorry, Didn’t get an alert I had a reply. I will try this . I even asked Apple Support if I could create a bootable installer from my 2011 Mac running High Sierra, but they said no. 🙄
    – 221b
    Jul 11, 2021 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .