My old Macbook has fallen and since then the keyboard works only partially.

  • I cannot login because my password uses characters that don't work.
  • An external Apple keyboard doesn't work.
  • In the past I've (very likely) set a firmware lock. When I boot into recovery mode, I see a lock and a password field.
    • In the firmware lock screen nothing works
    • Well I can move the mouse, and the CAPS lock key works, but nothing else.
    • I don't see a cursor
    • none of the keys work, except for the CAPS-lock key.
    • I can click the arrow in the password field, and nothing happens.

I don't have accessibility options enabled, and I don't see an onscreen keyboard. SSH could be enabled, I don't remember. The disk is encrypted, so I don't think SSH will start before the disk is decrypted. I don't have another Mac available right now and in the foreseeable future.

The laptop is linked to my Apple account, and I have my iPhone here. This is an early 2015 Macbook Retina. It has all updates installed, latest OS for this model, I can't remember which it is.

I have a Windows 11 laptop plus an USB-stick that can be wiped. Is it possible to put an installation ISO on the stick, boot from that?

I have an external backup disk with a bootable system disk on it, but I cannot use that unless I unlock the firmware lock. I have a Macbook M2 as well, but not here and I cannot access it now.

What can I do to login to my laptop?

  • I’m not going to go down the ISO road since your problem isn’t likely to be solved with any OS running on your hardware, you could look on this site for all manner of directions to make an ISO if you want to try that path.
    – bmike
    Oct 24, 2023 at 14:57
  • 2
    The lock and a password field means you have a firmware password set. You cannot boot from anything other than the internal drive without providing the password. Oct 24, 2023 at 15:09
  • How about a cheap usb keyboard, have you tried that? Oct 24, 2023 at 17:09
  • @MarcWilson, thanks for the insight.
    – SPRBRN
    Oct 24, 2023 at 18:46
  • @SteveChambers - I have an Apple USB keyboard here. It doesn't work with the firmware lock, and not with the normal login screen.
    – SPRBRN
    Oct 24, 2023 at 18:47

1 Answer 1


Perhaps a thunderbolt dock or display would let a USB keyboard (try PC ones and Mac ones) attached there work to attempt entering the firmware password and avoiding a repair to fix the USB and attached keyboard damage.

If not for the firmware password blocking recovery - I would take your Mac to another Mac and see if you can start yours in target disk mode. If so, the other Mac could try booting off your OS and provide the hardware needed to make a backup or set up network log in via Remote Desktop or SSH and configure your network access to attempt a network-only connection without being in target disk mode.

If your Mac has a firmware lock to prevent it from starting up to any external / remote source - you will have to enter that password or get it serviced.

enter image description here

  • Can you boot a Mac in TDM without specifying the firmware password if one is set? Oct 24, 2023 at 15:09
  • Firmware password implies you can not change the boot device at all - so no - that has to be released / known . Do you think the OP has a firmware lock - that might be a good clarifying edit / question - my assumption they have an account log in may be wrong.
    – bmike
    Oct 24, 2023 at 16:29
  • Bullet point #3 of the original posting. Oct 24, 2023 at 17:09
  • Worth an edit @MarcWilson (and apologies for deleting your earlier comment - that was an iPhone oops that I needed a computer to undo)
    – bmike
    Oct 24, 2023 at 17:59
  • Thanks @bmike. Apparently I have a firmware lock set on this laptop. It is set a long time ago, and I remember doing something like this but totally forgot about it. But why do none of the keys work when I try to enter the firmware password? It doesn't show any round bullets in the password field.
    – SPRBRN
    Oct 24, 2023 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .