0

Failed to open a session for the virtual machine Hadoop.

The virtual machine 'Hadoop' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: MachineWrap Interface: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}

I tried the below things.

sudo su
csrutil clear
reboot

Uninstalling and then re-installing Virtual Box multiple times. I did not receive any permission request to enable the blocked loading extensions in System preferences-->security.

csrutil enable 
reboot

I tried on a Mac intel chip 2017 and it runs perfectly fine. Not sure what to change for the M1 chip here.

1

VirtualBox does not run on an ARM chip such as the M1.
There's a long discussion on it here - https://forums.virtualbox.org/viewtopic.php?f=8&t=98742

Parallels have a functional beta & VMWare say there's one 'on the way' but as far as I know the only one that claims to be fully functional is UTM, which I haven't tried myself.
There's a setup guide on OWC's blog - UTM: Run Virtual Machines On Your Apple Silicon M1 Mac

1
  • Thank you for the information. – Kaumudi Mar 21 at 13:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .