A few months ago I got a brand new Mac mini 8,1 with T2 chip that was shipped with macOS Big Sur.

The first thing I did was to "secure" it by disabling Secure Boot and allowing External Boot; then I installed VMware ESXi (on an external flash drive) and wiped-out the internal SSD for provisioning the VMs. ESXi have been working well for my purposes.

Now I need to reinstall macOS on the internal SSD but I can't manage to do so. The Mac doesn't boot the installer program of macOS BigSur (nor Monterey) from the USB media: as soon as I select the USB disk to boot from, the Mac starts an Internet recovery that gets stuck with the world globe spinning indefinitely (I did numerous attempts and waited up to 12 hours).

I tried to reset the SMC / NVRAM / PRAM with no luck.

What's strange is that I can still boot other OSs (ESXi and Linux) from USB...

What could be the problem?

Remark: The internet connexion isn't at fault because the Mac is connected through 1Gb/s ethernet with an ISP bandwidth of 1Gb/s.

  • Internet recovery can be sketchy. If you've completely wiped the internal, then you will have removed the Recovery PArtition. Your best bet is to create an installer disk on a USB stick or other external volume, after downloading the MacOS installer. (But you'll need a functioning macOS to do that.
    – benwiggy
    Commented Jun 21, 2022 at 11:54
  • @benwiggy thanks for the comment; I’m already trying to install macOS from an USB stick generated on an other Mac with createinstallmedia
    – Fravadona
    Commented Jun 21, 2022 at 12:20
  • 1
    My 2018 Mac mini came with Catalina installed. I used another Mac to create a USB Mojave installer and was able to boot from this installer. I was able to use the Disk Utility to erase the internal drive and install Mojave. Later I installed Big Sur on an external thunderbolt 3 drive. Commented Jun 21, 2022 at 15:59
  • @DavidAnderson Good point, the Mac Mini Late 2018 is compatible with Catalina
    – Fravadona
    Commented Jun 21, 2022 at 16:37

1 Answer 1


I got a clue by booting BigSur's USB installer on a Mac with Mojave; it detected that the Mac needed a software update (not a firmware update) for the installer to work. IMO that's quite the dreadful requirement for an USB installer to need an update of the OS on the target Mac!!!

As my Mac Mini was listed in macOS Catalina's compatibility list, I tried to install Catalina,
with SUCCESS 👍

Remark: With macOS Catalina installed on the Mac, I can start the installer of BigSur from the USB media and even from the Internet recovery.

  • macOS 11+ installer can't boot on a "blank" Mac (i.e. without a macOS already installed on it) that has a T2 chip.

  • My Mac Mini was shipped with macOS BigSur, so the Internet recovery is tied to BigSur, which couldn't work because the Mac was blank.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .