1

I'm running MacOS High Sierra, and in the last few days it has started sending me notifications for US Holidays on the day before the holiday (I was notified about Valentine's Day and President's Day, but not about MLK Day last month). In Preferences I have notifications for all-day events set to None, which is the advice given in this Quora answer. It doesn't seem possible to edit the alert settings for individual events in this calendar.

The only change I've made recently is that added a subscription to our company's Outlook calendar. It also has a US Holidays calendar, but I have it unchecked, so I only see the holidays that come from Apple.

2
  • FWIW When I got my 16" MPB and Calendar had a bunch of holidays I didn't celebrate nor wanted to even see, I downloaded https://calendars.icloud.com/holidays/us_en-us.ics and edited it to my liking. Then I used the edited version of it for my holiday calendar. I have Show Holiday calendar unchecked in its preferences and I only see events from my edited version of the .ics file. This is in macOS Catalina and have not tested it in macOS High Sierra which you are running. – user3439894 Feb 14 at 15:16
  • Thanks. If it weren't for the notifications I could just ignore the holdidays I don't care about, and it's never been a problem in the past. – Barmar Feb 14 at 16:31
1

In the sidebar on the left, right click the appropriate calendar add-in & select Get Info.

The notifications switch/prefs is in there

enter image description here

4
  • That's what it already looks like. "Remove alerts" and "Ignore alerts" are both checked. – Barmar Feb 14 at 19:17
  • All I can say is it works for me. – Tetsujin Feb 14 at 19:18
  • It was working for me until yesterday, too. – Barmar Feb 14 at 19:19
  • Try toggle them all, reboot, toggle again. Maybe something got stuck. – Tetsujin Feb 14 at 19:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .