I have my work Exchange account syncing with the default Mac OS Calendar app. Until recently, this worked very well and I would get notifications (with sound) for forthcoming events.

For the last week or so, the notification sound has vanished. I still get pop-up notifications at the right time, but no sound.

My exchange account presents three calendars: "Calendar", "Birthdays" and "United Kingdom holidays". Interestingly, the holidays calendar showed an alert today and there was a sound! So the problem is limited to my 'Calendar' Exchange calendar.

Here's what I've tried so far:

  • I've looked in Notifications in System Preferences and ensured Calendar has "Play sound for notifications" enabled. I've also tried disabling and re-enabling this, to no avail.
  • I've looked in Sound in System Preferences and ensured alert volume is set appropriately. I've also got "Play sound effects through" set to MacBook Speakers.
  • Based on an answer below, I've tried removing the Exchange account from my Mac and re-adding it. No change.
  • I'm running Catalina 10.15.13 on a MacBook Pro (13-inch, 2019, Four Thunderbolt 3 ports).

Here are the alert settings within Calendar:

screenshot of alert settings

Any suggestions for how to resolve this?

  • Did you manage to solve this issue eventually? I have this same exact problem I wonder if this is a setting inside exchange itself..
    – CyberMew
    Oct 13, 2021 at 2:23
  • In the end I gave up and told Apple Calendar to alert me by default 5 mins before each event. This ignores whatever is chosen in Exchange, but at least caused a sound to happen. Oct 14, 2021 at 6:17

4 Answers 4


I've been dealing with Exchange/mail.app on iOS issues at my company for years and the only reliable way to deal with this problem is one of two ways.

  1. Delete the Exchange account from your iOS device and re-add it. Since everything on Exchange is kept on the server you will lose nothing but the time it takes to do this.
  2. Move your Exchange-based email account(s) to (the free) MS Outlook app for iOS.

Both of these seem like unfortunate choices, but both work. The Outlook email client is actually pretty good and (for me) allows me to keep my work and personal emails completely separate.

The issue with Exchange and mail.app not syncing up properly from time to time (and other, ahem..., issues) is an ongoing issue that (I have heard but cant find the source to cite) MS Blames on Apple and vice-versa. So there is no actual fix for the problem. Deleting the Exchange account for mail.app forces it to re-sync everything and (9 times out of 10) will fix the issue. Until it happens again, which is one of the reasons I migrated my work email to the outlook.app from MS.

If someone has discovered a permanent fix for this I would love to hear about it as it would save me that in-person interaction with (yet another) user and a lot of wasted time fiddling with it. So far it still exists on iOS 13.

  • How would option 2: "Move your Exchange-based email account(s) to (the free) MS Outlook app for iOS." affect whether the MacOS Calendar app makes notification sounds? I'm wondering if you misread my question. You have also referred to iOS several times, but I'm talking about MacOS. Mar 11, 2020 at 16:37
  • The problem is, most likely, an issue with events getting from the Exchange server. When I moved from mail.app to outlook.app my notifications were much more reliable, as was most everything else. mail.app and MS Exchange do not work and play well together, reliably. Mar 11, 2020 at 17:15
  • 2
    Unfortunately, this didn't help. Thanks for the suggestion. I was skeptical that it would make a difference, because my alerts are appearing at the right time. There is just no sound. Mar 16, 2020 at 16:59

enter image description here

System Preferences -> Notifications -> Calendar

  • 2
    As mentioned in my question, this is enabled. Apr 1, 2020 at 12:04

For me, the problem was in alert configuration. There were no events enabling at all. To fix this I just ran through all my accounts here and set them desired events settings and these settings were applied to all existing events.

Hope this will help.

enter image description here


I just found the answer here and it worked in Mojave.

Select Custom... in the dropdown

And the option Message with sound appears:

On my system, it doesn't show any indicator the alert will have sound, but the notification will play a system sound.
What I haven't found is how to customize witch sound plays, though. (it's a different sound than the one from System Prefs > Sound > Sound Effects)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .