2

my terminal is showing output in weird way and I don't know what it is called, so couldn't find similar question on this site, so pardon me for asking again.

This is the output on my terminal on MacOS 11.1 Big Sur:
enter image description here

As you can see the words are wrapped at first character.
I tried changing following things to fix: font, Oh-my-zsh theme. None worked.

My configuration for the terminal are:

  • Use Zsh - the default theme. .zshrc contents here
  • Use oh-my-zsh for the prompt and theme is powerlevel10k. Used robbyrussell theme for screen shot.
  • Font is Fira Mono, size 18.

Please tell me if I am missing something here to provide more details of my setup. Thank you.

6
  • 1
    Does the problem disappear if you run zsh without init files, or start bash? – nohillside Dec 27 '20 at 8:03
  • @nohillside yes, starting new shell directly with bash and zsh -d -f -i commands does not give this problem. – Edward Torvalds Dec 27 '20 at 8:08
  • @nohillside do you think there is something wrong with my .zshrc file? Can you point it out? Thanks for your comment. – Edward Torvalds Dec 27 '20 at 8:32
  • 2
    There definitively is something amiss in one of the init files. If it is a recent thing, just start undoing the latest changes. Or start to rebuild it from scratch. – nohillside Dec 27 '20 at 8:44
  • @nohillside I deleted current .zshrc file, created empty one, installed oh-my-zsh and powerlevel10k theme again and terminal is working just fine. Thanks for your help. – Edward Torvalds Dec 28 '20 at 11:43
3

I actually found out that the cause of the issue was this line tabs 4 in .zshrc. This worked on very well for me on Linux using Konsole terminal. I had copied my code configs from Linux after switching.

Update:

I found out that MacOS terminal uses negative values to the tabs command instead of positive. So for example, for width of 4 spaces, it should tabs -4. On Linux, it should be tabs 4 to achieve the same.

1
  • 2
    Wow, I didn't even know there was a tabs command :-) – nohillside Dec 29 '20 at 9:19
1

Such small config issues are difficult to diagnose and resolve. What might help is

  • Rollback init files to last good version (e.g. by getting them from Time Machine)
  • Start a shell without init files (bash --noprofile/zsh -d -f)
  • Rename existing init files and rebuild them line by line
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .