9

I have a problem with using Powerline fonts in the iTerm2. I followed the tutorial for installation and I have chosen Hack font in the profile settings (Non-ASCII is set just to make sure). My .zshrc file is here if it helps.

enter image description here

However, the prompt still looks like this

enter image description here

I am running Mojave with ZSH 5.7.1 (I am not sure if any ZSH configuration applies to this issue). Thanks a lot for help

1
  • Nerd font might help. There's no harm in trying I guess.
    – anshu957
    Sep 12, 2019 at 19:40

2 Answers 2

23

Go to iTerms2 Preferences (cmd ⌘+,) then go to Profiles and check the box called "Use build-in Powerline glyphs"

1
  • wow! so beautiful
    – chendu
    Jun 16, 2023 at 8:27
3

I am not sure about the setup that you did. But the following process worked on my system:

https://medium.com/@elviocavalcante/5-steps-to-improve-your-terminal-appearance-on-mac-osx-f58b20058c84

I suggest you change the theme from default ZSH_THEME="robbyrussell" to ZSH_THEME="agnoster".

The above guideline helped me to get the font in terminal and in iterm2 too

enter image description here

1
  • I am not using Oh My Zsh, I attached my zshrc if it helps. But yes, I followed the steps 4 and 5, otherwise I wouldn't be able to add the fonts into the iTerm. Sep 9, 2019 at 15:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .