1

I have a strange issue on my MacBook Pro (Mid-2017 15" with touch bar; MacBookPro14,3; 11.0 Beta (20A4299v)).

I've just installed macOS Big Sur on an external drive and everything was alright for some time. Terminal app was working perfectly and I still has one window open with it working OK.

The last step I remember doing was downloading and installing iTerm and adding it to the Full Disk Access on Privacy Control Panel before executing it.

After this, every time I open any terminal prompt, with the default app or iTerm, zsh, bash, etc., does not appear, and the window shows login "Terminal - login" and it does not show prompt.

NOTE: I know it refers to a beta OS but this problem has already appeared on other macOS versions. I tried the steps on both of these links but none solved it:

Any ideas?

  • 3
    Please see this question and answers regarding asking questions about Apple's beta software. You'll need to edit your question to include the relevant info regarding version/build and hardware type. Also, be sure you've opened a Feedback to Apple about this issue. – fsb Jul 5 at 18:09
  • Undo the edit you made to the startup file(s) for whichever shell you are using. – Marc Wilson Jul 5 at 19:07
  • I have done that. And restarted. It works again but stops working after a while. Create a new user, switch to this new user, opens a terminal window and the same problem persists. This problem appeared on other versions of the OS (see links I've put in the question), so I guess its not related to BigSur... – Marcus Neves Jul 5 at 20:39
  • And yes, I opened a Feedback for apple too. Thanks for any help! – Marcus Neves Jul 5 at 20:48
  • Can you add a screenshot of Terminal showing this behavior? Which shell is configured in Terminal under Preferences>General>Shels open with? – jaume Jul 6 at 5:42
0

Typically this is a dot file causing the shell to hang.

  1. Make a new account and log out of the old one - log in to the new and open the shell. If it hangs, too - you have system level configuration files to blame in most cases. Reinstall the OS if you can’t Seuss that out.
  2. If that works fine, then su - hanguser to confirm it’s that one account.
  3. You can run the shell without the rc dot files as well.

Also, before you try anything shut down the OS and validate it happens after a restart, basically try to avoid needing to go through this laundry list of potential issues:

| improve this answer | |
  • Thanks for your reply. I've done almost everything both those articles mentions. Also freezes on a fresh account. This is a fresh install on an external disk. My normal macOS Catalina install is ok and works well. So I found this strange because after years using macOS never encountered this. – Marcus Neves Jul 5 at 20:50
0

On one of the articles I’ve mentioned shows a command (sudo rm -rf /private/var/log/asl/*). I ran this and reboot. It worked ! I'll update this if the problem returns! Thank you all!

| improve this answer | |
  • Could you find this article? That solution doesn't make sense - the only way I could think log files would cause an issue is if they were consuming too much disk space and the removal of then freed up the space needed. – HankCa Nov 22 at 5:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .