4

An app I developed works fines with my iPhone 8 running iOS 13.6.1. But when I go to test it on another phone, I receive this error: "This iPhone 7 Plus (Model 1661, 1784, 1785, 1786) is running iOS 13.6.1 (17G80), which is not supported by Xcode 11.7."

I looked at upgrading to Xcode 12 but apparently it's still in beta?

Any suggestion on what's needed to make this combination compatible?

4

Seems that Xcode 11.7 is missing some files.

This topic has helped me: https://developer.apple.com/forums/thread/659166

Or try to upgrade your iPhone 7 Plus to iOS 13.7.

0

iOS 13.6.1 should be very well supported by Xcode 11.7. Try connecting the iPhone 7 Plus via cable to your Mac and try if you can see it as a run destination in Xcode 11.7.

You need not and should not upgrade to Xcode 12, it's still in beta and comes with iOS 14 SDK.

1
  • I receive the error when I attach the iPhone 7 Plus with a cable to my mac running Xcode. I originally connected it to view the console to understand why my app crashes on the iPhone 7 but successfully runs on other phones? Thanks for confirming that this phone should be compatible with Xcode 11.7. – dhesford Sep 6 '20 at 1:51

Not the answer you're looking for? Browse other questions tagged .