2

This isn't a coding question, but it is an issue that affects my ability to develop iPhone apps. Beginning this morning, I began seeing the message "The cable or accessory is not certified and may not work reliably with this iPhone" whenever I plug in my iPhone 5's cable. I'm running iOS 7.0.4.

(This is the cable that came in the box with the phone, and I get the same message when I use the cable that came with my iPad.)

The phone will still charge (as long as I have the correct side of the jack "up"; it previously didn't matter which side was "up"). But Xcode no longer recognizes the device, meaning I can't test with it. (iTunes doesn't recognize it either.)

Does anyone know what causes this issue and how to fix it? I didn't have this problem yesterday and have made no deliberate updates to the phone recently. And as I said, I'm using cables that were shipped boxed with Apple devices.

migrated from stackoverflow.com Jan 29 '14 at 16:19

This question came from our site for professional and enthusiast programmers.

  • 1
    get the new one, or replace it in the apple store – Eugene Pinchuk Jan 29 '14 at 13:56
  • Looks like your lead is broken : discussions.apple.com/thread/5326636 – Ohnomycoco Jan 29 '14 at 13:57
  • Thanks for the link to the thread. There are good suggestions there and I'll give them a try. – jrciv Jan 29 '14 at 14:05
  • If there is a newer cable I will get it. I just wondered if anyone knew of a software fix before I went to the Apple store. Thanks for the help. – jrciv Jan 29 '14 at 14:08
2

As you can see in several threads like the one pointed by @Ohnomycoco, this is not a software problem but a hardware problem.

Lighting a "smart" connector with a microchip build-in the cables head. It's most likely due to a damage cable, so you'll have to replace it.

Also - be sure to test since in many cases it's the iOS device that needs repair and not the cable:

  • Thank you. But I doubt it is the cable as I have tried two. And the MacBook is able to detect the iPad. So if it is a hardware issue, then it is likely the phone itself, which is the last thing I wanted it to be. – John Jan 29 '14 at 16:55
  • Did you check if there was some dust/dirt in the connector ? – Matthieu Riegler Jan 29 '14 at 19:17
  • I'm holding out hope that it is dust. It looks like it could be. I think I will take it to the Apple store and ask them to take a look. Thanks again. – John Jan 29 '14 at 20:57
  • I finally took my phone to the Apple Store. The Genius just cleaned out the connector and now it works fine. – John Apr 10 '14 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .