0

I have a MBP running OS X Mojave (10.14.2)

Any USB drive I connect is always read-only and I can never write to it. I've tried the following:

  • Multiple USB sticks
  • Multiple USB-C slots (just in case)
  • Formatting a drive as FAT32
  • Formatting a drive as ExFAT
  • Restarting (with and without the USB plugged in)
  • Confirmed the USB is write-able from a Windows laptop
  • Confirmed there is no physical write-protection switch on the USB

In each case I'm consistently blocked from writing to the USB drive, both from the UI and via the command line.

See below the "Get Info" display for a freshly formatted 32GB ExFAT drive. Note the permissions are "ready only" at the very bottom

Any idea what the issue could be here or what else I could try?

Thanks!

enter image description here

2
  • 1
    Looking at the Created: and Modified: date/time, you definitely have an issue! If you boot to safe mode are you able to format and then read and write from the USB drive, while in safe mode? Have a look at: How to use safe mode on your Mac – user3439894 Aug 19 '20 at 4:41
  • Welcome to Ask Different. As a further test, if you use HFS+ or APFS instead of exFAT or FAT32, is the USB drive writable? – jaume Aug 19 '20 at 10:19
1

There is two possibilities here:

  1. Your drive is mounted as read-only
  2. You do not have permission writing to the filesystem

(The system can definitely write to the drive because you can format the drive)

To address the first one, please enter the following command in Terminal:

mount

You should get something like this:

/dev/disk1s1 on / (apfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
/dev/disk1s4 on /private/var/vm (apfs, local, noexec, journaled, noatime, nobrowse)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, nobrowse)
/dev/disk#s# on /volumes/<drive name> (ExFAT, local, (...))

Look at the line that say ... on /volumes/NONAME, and see if there is a "read-only" in the bracket, like this one:

com.apple.TimeMachine.2020-08-15-213432@/dev/disk1s1 on /volumes/BK/Snapshots/2020-08-15-213432 (apfs, local, noexec, read-only, journaled, nobrowse)

If there is, try:

mount -uw /volumes/NONAME

and see if you can write to the disk. There is probably a record in your /etc/fstab that causes the mount to be readonly.

If your drive is readonly for whatever reason, you should get this error:

root@Joys-MacBook-Pro /p/v/root# hdiutil attach -readonly test.dmg
/dev/disk2              GUID_partition_scheme           
/dev/disk2s1            Microsoft Basic Data            /Volumes/1 1
root@Joys-MacBook-Pro /p/v/root# mount | grep /volumes/1\ 1
/dev/disk2s1 on /volumes/1 1 (exfat, local, nodev, nosuid, read-only, noowners)
root@Joys-MacBook-Pro /p/v/root# mount -uw /volumes/1\ 1/
mount: unknown special file or file system /volumes/1 1/.

You should not get any other errors. If you do, edit your question to include a complete log of commands you type and the result. (Or put it in the comments).

If that is not the case, then it's likely a permission issue. In your terminal, enter:

sudo -i

and enter your password. The password will NOT show on your screen. When you are done, hit enter. Then, enter the following:

touch /volumes/NONAME/1

and see if there is any error. If not, then it's a permission issue. Execute the following command:

chown -R <your account name here> /volumes/NONAME
chmod -R 755 /volumes/NONAME
exit

See if you can write to the folder. If not, then there is something wrong with your system. You can consider reinstalling it (this won't remove your application, settings, or data).

6
  • Thanks, the volume is indeed read-only. First I tried mounting as write-able but I get the error mount_exfat: /dev/disk2s1 on /Volumes/NONAME: Operation not permitted. Then I tried sudo -i and I still could not touch a file on the disk: touch: /Volumes/NONAME/1: Read-only file system. I'm very surprised a root user can't write to the disk. I don't see an etc/fstab file on my system - any idea what could be corrupted? – abhchand Aug 19 '20 at 14:52
  • When I look at /Volumes/NONAME I see that it's owner and group are both _unknown, which I've never seen before – abhchand Aug 19 '20 at 14:54
  • This is very unusual. Try starting in recovery mode and see if the disk is read-only. – Joy Jin Aug 20 '20 at 4:01
  • You should get this error instead if your device is read-only: mount_exfat -o noowners,rw /dev/disk2s1 /volumes/2 mount_exfat: /dev/disk2s1 on /volumes/2: Permission denied – Joy Jin Aug 20 '20 at 4:15
  • Perhaps post the output of diskutil activity while you execute the commands. – Joy Jin Aug 20 '20 at 4:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .