2

Current backup solution

  • Macbook Pro 13" (2020) running macOS 14.4.1 Sonoma
  • Seagate 1TB external USB 3 drive formatted as Mac OS Extended (Case-sensitive, Journaled)/Master Boot Record

I would like to migrate to a network backup solution. I currently have a TP-Link Archer AX50 AX3000 Wireless Dual-Band Gigabit Router that supports Time Machine backups over the network. (The router supports drives formatted as FAT32, exFat, NTFS, and HFS+ connected via USB.)

The problem is that Time Machine does not see the drive no matter how I have it formatted. (I am using a Maxtor 300 GB drive for testing so as not to lose my current backups.)

I have tried the following formatting:

Format Scheme
APFS GUID Partition Map
APFS (Case-sensitive) GUID Partition Map
Mac OS Extended (Journaled) GUID Partition Map
Mac OS Extended (Case-sensitive, Journaled) GUID Partition Map
Mac OS Extended (Journaled) Master Boot Record
Mac OS Extended (Case-sensitive, Journaled) Master Boot Record
ExFAT Master Boot Record
Mac OS Extended (Journaled) Apple Partition Map
Mac OS Extended (Case-sensitive, Journaled) Apple Partition Map

I can access the shared drive via SMB by browsing the Network and connecting to the server using the IP address. When I try to add the drive in the Time Machine settings, it says "No Available Time Machine Destinations".

I have even connected the drive to my MBP via USB and formatted it from within the Time Machine settings then unmounted the drive and connected it to the router; it is still not seen.

Previously on a whim, I had formatted a flash drive to test out if I could get a network backup solution, and that worked (though it was several months back).

What step(s) am I missing that is not allowing Time Machine to see the drive?

16
  • From a brief perusal of searches in Google for Sonoma and SMB, nobody is happy about it and it generally doesn't work, or work well. This question at AskDifferent may be helpful: apple.stackexchange.com/questions/465152/…
    – IconDaemon
    Commented Apr 5 at 22:44
  • Did you enable Time Machine Support on the router’s settings? See the user manual for details
    – Allan
    Commented Apr 5 at 23:18
  • @Allan Yes. I also tried with authentication on and off.
    – agarza
    Commented Apr 5 at 23:38
  • Also see this Apple Support document for the types of formats supported.
    – Allan
    Commented Apr 5 at 23:40
  • Yeah, I have referenced that page several times trying to get this to work.
    – agarza
    Commented Apr 5 at 23:41

1 Answer 1

0

Note: This is not a solution to the problem but provides some insight into what is happening.


I followed the instructions for Quick Apple Raspberry Pi Machine and formatted a hard drive to HFS+ and installed netatalk on a Raspberry Pi 3B clone; everything worked fine.

I went into Time Machine settings and the network drive was recognized and added. Since this was over ethernet, the backup took about 13 hours to complete.

I did try connecting the drive to my Archer AX50 and configured the settings for a Time Machine shared drive. Time Machine did not see the drive. This seems logical since the router shares the drive using Samba/SMB, not netatalk.

Conclusion:

A recent update to macOS Sonoma has broken the ability for Time Machine to see a network drive; this is probably somewhere within the Samba/SMB protocols implemented by Apple.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .