0

I bought a SanDisk USB drive about a month ago. It's currently formatted as MS-DOS (Fat32), and it's stuck on read-only and I'm not sure how to fix it. (and there is no physical switch on the usb) In particular, under 'Sharing & Permissions' of 'Get Info' it just says 'You can only read'.

Using Disk Utility I tried 'First Aid', which failed:

enter image description here

I also tried 'Erase', which also failed:

enter image description here

Then I tried 'Erase' on the disk, didn't work either:

enter image description here

I've also tried a no. of commands in terminal:

diskutil eraseDisk free EMPTY /dev/disk2
>> Unable to begin erase operation: A writable disk is required (-69772)
diskutil unmountDisk force /dev/disk2
diskutil eraseVolume free free /dev/disk2
>> Error: -69888: Couldn't unmount disk
sudo dd if=/dev/zero of=/dev/disk2 bs=1024 count=1024
>> dd: /dev/disk2: Permission denied
1

Try format it in another computer - anything will do. If it still won't, or if it shows the same data even after formatting, assume the write-protect firmware has kicked in & it's now dead.

There's a full work-through of this issue on our sister site, Super User - What can I do if my USB flash drive is write-protected or read-only?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .