1

This is strange. I formatted my 16 GB USB drive on OS X El Capitan with FAT file system and it worked fine. However, same drive on Windows 7 PC shows only 200 MB of size. Where the heck other drive size gone? I reformatted it with EXFAT this time and no problem of size on El Capitan but again it shows only 200 MB size available on PC. Tried to format it again with Windows this time but no help. Where all of my USB size gone? I had no issues formatting and using it properly on Yosemite or Mavericks. Any suggestions??

  • You formatted the drive using a GUID partition scheme. Your probably should have used a MBR scheme. – David Anderson Apr 28 '16 at 5:16
1

By default, Macs format all drives with the GUID partition scheme (GPT). A particular feature of GPT is the EFI system partition, which on a Mac defaults to 200 MB in size. The EFI partition is also FAT32.

Windows supports GPT just fine, but it does not support multiple partitions on a USB flash drive. Windows will only see the first partition, which is the 200MB EFI partition. It is the only operating system that has this limitation.

To reformat this drive, you will need to select the Master Boot Record (MBR) partitioning scheme in Disk Utility in order for Windows to use it. You must also ensure that you create only a single partition that spans the whole drive.

  • Resolved. I booted into my Yosemite disk and with its Disk Utility formatted the USB with FAT file system. The USB size is now 14.2 GB on Windows OS. Thanks for your Support. – Ran Franco May 5 '16 at 3:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .