1

Background Info: A day ago, I got a new MacBook Pro 16 with Catalina installed for work, this is my first Mac. I got everything set up on my laptop and proceeded to get my development environment setup. During this setup, I was messing with permissions around my root directory (big mistake, I know). After messing around with permissions, the 'sudo' command would error out as well as other issues like System Preferences not opening. I tried a few things, but eventually called Apple to get support. They suggested the only way to really fix this issue is to reinstall MacOS.

The Current Issue: Apple support was unable to help me reinstall MacOS. We tried to reinstall via Recovery Mode and it would error out each time at the end of the installation. Below is the error I receive when trying to install MacOS: Installation Error

We have deleted and recreated the Macintosh HD image and tried installing after that, reset the SMC, ran First Aid on the image. Nothing has worked, every time I try to install MacOS I get this error. The error also appears at the very end of the download / installation process, usually at the '2 Minutes Remaining' mark.

Please let me know if I can provide more information.

0

There was a known issue with upgrading or installing Macs with a T2 chip, such as yours, to macOS 10.15.6. Apple have yet to acknowledge the problem but have rolled out (about 3 hours ago) a new update to the software catalog that is reported to fix the problem.

Give it another try now.

1
  • Wow, it worked. Can't believe there wasn't any communication about this issue. Thanks for letting me know, Tony. – user3362085 Aug 6 '20 at 14:46
0

Tony looks to have the scoop here on an installer selection error for about 24 hours yesterday. Try again exactly what you did previously after 0000 UTC Thursday 6 August.


When you power it off, I would attempt a second time to do an erase install.

  1. Hold Option-Command-R at start.
  2. Use Disk Utility when you are to the “install” screen - delete all the volumes - especially if you have more than one that says “Data”
  3. Then Erase the entire drive - leave Untitled as the title.
  4. Then install macOS

If that doesn’t work, you may have a hardware issue and need to contact support.

Or perhaps try the App Store - step 2 in this other answer.

4
  • Unfortunately this did not work. Tried this with Apple, and tried again as you suggested and got the same error. Thanks for trying though. – user3362085 Aug 5 '20 at 18:29
  • Wow @user3362085 . Apple didn’t have a suggestion or offer repair? – bmike Aug 5 '20 at 22:58
  • @user3362085 this may all be resolved by Apple releasing a new build and now patching that to work again. See my edit here and this post there. – bmike Aug 6 '20 at 1:34
  • They told me I would have to take it to the Apple store to get it looked at by a Genius tech – user3362085 Aug 6 '20 at 14:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .