0

I have an early 2015 MacBook Air - which had macOS Monterey installed that I want to exchange with my new Macbook Pro. So I erased the Air using the steps provided in the official Apple Support website.

Now, when the system restarted it showed a folder with a flashing question mark (??) since it was not able to find anything to boot.

I restarted the MBA in recovery mode and tried to re-install macOS, after which it did some pre-checks and prompted me to install Sierra

It failed at last step of the installation stating “Error Occurred while Preparing the Installation” error. I have now tried it thrice but I keep getting the same error.

I've also tried Disk Utility - ran First Aid on the disk and then re-installing Sierra. It is not working and fails at the same last step.

Installation Error

[Update 1] I was on call with Apple Support for almost 1.5 hrs today and they were not able to solve the issue. This issue persists even after erasing the disc using “HFS+ [Mac Extended, Journaled]” as suggested in the comments. Apple Support has finally asked me to go ahead and create a bootable installer to try and boot from an external device.

9
  • Sierra cannot see APFS. Try again with HFS+ [Mac extended, journaled]
    – Tetsujin
    Feb 4, 2023 at 19:07
  • Apple did not make any MacBook Air models in late 2015. Feb 4, 2023 at 20:05
  • @Tetsujin: I believe Sierra can see APFS, but can not be installed to an APFS volume. Feb 4, 2023 at 20:32
  • 1
    Did you try holding down the Option-Command-R keys during startup? This should boot your Mac to internet recover and then allow you install macOS Monterey to an APFS volume. Feb 5, 2023 at 16:03
  • 1
    Out of curiosity, is there a reason for installing such an old version? Prior to Apple Silicon (Big Sur release), I have found Catalina the rock solid stable version of the bunch and prior to that, El Cap.
    – Allan
    Feb 5, 2023 at 17:00

1 Answer 1

1

I have an early 2015 macbook air and I had the exact same issue. A possible fix could be, go to utilites when you are in macOS Utilities (top left of the screen) then click startup security utility, enter password (create a password if you don't have one and restart if it tells you and go back to the utilities), under Secure Boot, click Medium Security and under Allowed Boot Media, click Allow booting from external or removable media. Then try to install macOS (restart if it doesn't work the first time).

If that method does not work, install a bootable USB that the GB needed can vary depending on the size of the macOS. (You need another mac for this, you can do it on windows, but I couldn't get it to work) https://www.youtube.com/watch?v=AUOx0b3YjlI Follow this from 0 to 5:37 and 5:37 to 7:27 is an example of the fix I explained above. I didn't search up the macOS on apple store because it didn't pop up, so I typed it on google and clicked on the link from apple and it took me to the apple store and I installed macOS Big Sur and made sure it was compatible to my mac. (Depending on the version the mac you are using to install, the macOS can vary, a good rule is to install the macOS that is compatible with your mac you are using to install or the current macOS of the mac you are using to install). After your done creating the bootable USB (Follow 7:38 to 8:29 and 9:26 to the end is the installing the macOS for this part and 8:30 to 9:25, if you need it, is about the internal hard drive), plug the USB in the mac and turn it on and immediately hold option. You'll see the USB name and click on it (the arrow). For the internal hard drive I erased used Mac extended (Journal), but this may vary depending on the macOS you used. Then I downloaded the macOS and it took a while. If it freezes, turn it off and turn it back on again or go and install the macOS again through cmd + r.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .