1

A long time ago (and on another machine) I bought a Mac App Store app (EventScripts) which is still available in the store.

I now have a new iMac (with macOS Mojave) where I haven't installed this app. However the Mac App Store on this app always notifies me that it wants to update this app. Here a screenshot from the "Updates" pane in the Mac App Store on this iMac: Mac App Store Update pane

How can I get rid of this notification (whileof course keeping the valid update notifications for other apps)?


More info:

The app is definitely not installed, because it does not appear in the /Application folder,

Strangely though, when I search for the app in the Mac App Store I get not a "Get" Button, but an "Update" button:

enter image description here

I guess it has something specific to do with this app which for many years did not get updates, but now it suddenly does get an update.

  • It really looks like the Mac thinks the app is installed... If you search for the app in the App Store, is there a button that says "Open" or "Get"? What happens If you press "Update"? Could you open the App Store preferences and see if "Automatically download apps purchased on other devices" is checked? – jaume Jul 28 at 13:37
  • @jaume Thanks for chiming in! When I search for the app in the Mac App Store it says "Update" (see 2nd screenshot in updated question). Also "Automatically download apps purchased on other Mac computers" is not checked. – halloleo Jul 28 at 13:43
  • When you moved from the old Mac to the new one, did you do a Time Machine restore, Migration Assistant or something else? I’m thinking that the app is still registered with LaunchServices despite never having been installed on this Mac. – Allan Jul 28 at 14:22
  • Thank you for coming back to me. I'm wondering... if you update the app, you will see an "Open" button in the App Store description for EventScripts. If you press the button, do you get an error or does the app launch? – jaume Jul 28 at 14:23
  • Try running this command /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -dump | grep -i eventscripts. (You might want to create a Symlink to a folder in your path to that command for ease of access) – Allan Jul 28 at 14:39
0

One simple way to stop this would be to go ahead with the update and let it do what it wants to do. If it installs the app you can then remove it. The app could be in a different folder than applications. Have you tried searching for the app name using Spotlight search or a Finder Search? The update button in the App Store just says it thinks the app is on your machine.

| improve this answer | |
  • Well, the app is not on the core volume, but on a backup volume (containing a bootable clone of an old machine with EventScripts). Any way to tell macos not to look on the external backup volume? – halloleo Jul 29 at 1:59
  • Worked it out, @smh: (1) Exclude the backup drive in Spotlight and (2) rebuild the LS database. No need for details. – halloleo Jul 29 at 2:14
0

This answer is initiated by a comment from @Allan pointing me to the macOS system command lsregister. After ssuing

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -dump

I could see that EventScripts was listed as an application - with the path on an external backup volume!

So now I knew what the steps to cure the problem are:

  1. Making sure that Launch Services does not look on the external backup drive for applications. For this I excluded the external drive from Spotlight (System Preferences -> Spotlight -> Privacy).

  2. Finally reindexing the Launch Services database. I did this with

     /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -v -all u,s,l
    

After restarting the machine EventScripts is now - voila! - gone from Mac App Store's Update pane.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .