This is the notification that pops up from the App Store on Mountain Lion:

enter image description here

As you can see, the only options are Details and Update. Most of these banners have a 'close' button, to dismiss the notification without taking an action. On this one though, it seems like the only action I can take is opening the App Store with it.

Just clicking the x in the Notification Center list doesn't get rid of this actual notification.

How can I close this without taking the time to open up the App Store?

5 Answers 5


To dismiss the notification temporarily:

Click and hold the banner and flick it to the right to put that notification in Notification Center. If you are using a Trackpad, You can hover over the alert and use two fingers to flick it to the left.

The notification will still remain in the Notification Center until you update.

Unfortunately, there is currently no way to dismiss the notification permanently.

  • 1
    Sorry, but this doesn't work duci9y. It only gets rid of it for a short amount of time, then it come right back to my screen to bother me later. I want to turn off App store update notifications entirely. How do we do that?
    – user34030
    Commented Nov 3, 2012 at 16:15
  • Sorry, I don’t know how to permanently disable it. That question deserves its own post.
    – duci9y
    Commented Nov 4, 2012 at 9:57
  • I just asked this question about permanently dismissing it: apple.stackexchange.com/questions/72784/… Unfortunately, from the comments here, it doesn't seem possible.
    – g .
    Commented Nov 26, 2012 at 18:14

Yep, duci9y's answer is the only real way to "dismiss" it. Unfortunately, Apple does not allow you to alter the type of notification. Therefore, there is never a close button. Now, if you are using a non-apple mouse, then you will have some problems doing duci9y's answer. I believe the only way you can dismiss it with a regular mouse would be to click on the notification button on the top right of the screen and then turn off notifications and then turn it back on.

It's not convenient, but that's how it works.

  • You should read the first sentence of my answer. Maybe “drag” isn’t the right word, so I changed it.
    – duci9y
    Commented Oct 12, 2012 at 16:23
  • Actually, dragging would make more sense, but it says "flick". To me that implies swiping, oh but by the way, I think you meant to say right, not left.
    – Josiah
    Commented Oct 12, 2012 at 18:56
  • Woah Thanks! I completely missed that. Actually flicking will make more sense, as the box will bounce back sometimes if you try to drag it instead of flicking it.
    – duci9y
    Commented Oct 13, 2012 at 6:41
  • 1
    Perhaps you should say: "Click and hold the banner and then flick it over to the right."
    – Josiah
    Commented Oct 13, 2012 at 18:52

You can turn off this notification. It's annoying AF. Go to your System Preferences and then to Software Update... UNCHECK THAT BOX for Automatically check for updates. That banner will leave you alone now! Good Riddance.


  • I already have this off, but the system keeps checking (and notifying) anyway. Looks like a plain bug to me.
    – q.undertow
    Commented Nov 11, 2021 at 2:50

Clicking on the banner itself -- not either of the buttons -- opens the App Store. You can Quit or Close the App Store window, and the banner disappears. I just discovered this, so I don't know whether it will come back . . .


on terminal

launchctl unload -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist

source: http://osxdaily.com/2012/08/06/disable-notification-center-remove-menu-bar-icon-os-x/

  • and you can use 'load' instead 'unload' to rollback this change ! Commented Feb 4, 2014 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .