1

All of my MacBook Pro 13" 2017 backups are kept on my Toshiba External HDD. I decided to update my MacBook to macOS Big Sur developer beta (because I am a dev) and test it out. I backed my MacBook up onto my external hard drive before installing macOS 11 Big Sur beta, expecting to be able to use it just in case I need to go back to macOS Catalina.

After I installed the beta:

Just about a half a week ago, after using the drive completely fine in macOS Big Sur, I plugged in my external hard drive and found that it did not appear on my desktop or in Finder. I opened Disk Utility to find that the disk was displayed as not mounted. I tried to click Mount, which was not greyed out, and I received an error that the disk could not be mounted:

Could not mount “TOSHIBA EXT”. (com.apple.DiskManagement.disenter error 0.)

I automatically assumed that this was just a bug in the new beta update and I reported it to Apple. However, I soon came to find out it was also happening on another MacBook Air that has macOS Catalina 10.14.2 installed. So it was obviously not the beta, it was the disk.

Why exactly did this happen on a disk that was working perfectly fine the day before? Was the disk affected by something in the macOS Big Sur beta or is it a completely unrelated issue? I was searching for solutions for this issue and found that it was somewhat common, and that people recommend using DiskWarrior to repair the disk, however, I cannot justify spending $100 to repair a disk when I might as well just buy a newer and faster SSD. Are there any other cheaper and even free solutions to this?

And in terms of data, I do not have data on the disk that is vital except for my MacBook Pro backups, which I was hoping to have on hand if something went wrong. If I bought a new drive, could I back up that from macOS Big Sur, erase Big Sur and install Catalina with the data from Big Sur?

3
  • What's the output of diskutil list? – Joy Jin Nov 17 '20 at 9:36
  • And an important point to add on to Allan's answer: if you have a broken drive, you have a better chance to recover your data if you first use ddrescue to make a block copy of your drive to another good drive, then use other recovery utilities. Remember that the more you read off the broken drive (esp. if you scan with multiple data recovery softwares), the faster and more likely it will break completely. – Joy Jin Nov 18 '20 at 3:28
  • I am also getting the same error, it is formatted with MacOS Extended (Journaled). It was working fine the day before upgrading to BigSur OS. – kamal Nov 19 '20 at 12:10
1

Why exactly did this happen on a disk that was working perfectly fine, driving down the same road the day before?

For the exact same reason your car breaks down on the road when it was working perfectly the day before. In other words C'est la vie.

Is it your drive or the enclosure?

Now, as to your situation, you've presumed that the drive went bad without ruling out the other factor - the enclosure itself. The USB port would be the third factor, but you automatically ruled that out by going to a different computer.

There's a very similar question to yours already posted: External Hard Drive no longer working. That one involves an enclosure and an SSD, not an HDD like yours, but the principles are the same.

Recovering your data

It's a bit confusing as to what's exactly on the external drive - data or backups. If it's backups, there's really no need to expend the time and money to recover something. Get that external SSD and just continue making backups like you normally have.

If it's data - you need to determine what that data is worth to do. For data recovery, I've used DiskDrill; it's absolutely free to scan and see if your files are recoverable and if they are the software is (IMO) reasonably priced at $90USD. If your data needs to be recovered, it's a cheap price to pay to get it back - it's also a good reminder to back up your data wherever it exists; - on your boot drive and your external drives!

1
  • 1
    So, I have determined that it is really not worth saving the drive at this point. And yes your right, sh*t happens. To clear things up, the drive is partitioned. Part of the drive stores Time Machine backups of my MacBook Pro, the other partition of the drive stores game data. The thing is, I am getting a new PC very soon (like in the coming weeks hopefully) so I am just going to install the games as a new install on the PC anyways. In that case, I'm just better off getting a new SSD to store backups instead of trying to save the old ones. Thanks for the help though! – m_de41 Jul 6 '20 at 14:41
0

In case your drive is not corrupted, there is a 3rd party app called Mountain that I use to mount drives that wont mount normally. The app is not free but comes with a free trial. To get the free trial go to the link I've included above.

2
  • As I mentioned in Allan's comments section, I decided to just get a new SSD when I get the chance. The drive isn't really worth saving since I'm going to be installing the games that were stored on the drive onto a new computer, and I'll just do backups on a new SSD, and not save the old ones. I overestimated the severity of the issue to be honest. – m_de41 Jul 6 '20 at 14:43
  • Thank you for the resource anyways! – m_de41 Jul 6 '20 at 14:43
0

I'm by no means a computer specialist but think the issue is that you had your time machine backup and your drive probably got too full and ceased to work which is what happened to one of mine. I would keep a separate drive dedicated to time machine backups and your files on a separate drive. The drive will not work if its filled to capacity.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .