2

I have been having this problem with a Macbook Pro late 2006 and a Macbook Pro early 2011.

Macbook Pro refuses to mount an specific external hard drive or USB stick, after being able to do so with no problem before, and usually after the operating system disconnects it suddenly.

That particular external hard drive or USB stick is perfectly good since it works OK under linux.

MBP would mount the drive month later when tried again.

It have happen with two external Western Digital Hardrives (myPassport) as well as with a Kingston USB stick.

Disk Utility sees the drive but cannot mount it because it's "incompatible".

Many people seem to be having this problem and no solution has been found.

I cannot format the disk because that's where my backups are.

Again: a Linux box uses the drive with no problem. I don't have another mac at hand to try.

Now I'm going to buy another external hard drive from Amazon.

Which brand and model should I buy in order not ti have this problem again?

1

This seems like an issue with the chosen file system.

What file system did you choose when formatting the hard drive? If it's not HFS(+), FAT in any fashion or NTFS you cannot read it on OS X without additional software. If it's Ext, you could go with Paragon's Ext for Mac (but it costs some bucks).

In future, best choose exFAT when formatting an external hard drive if you need to use it on different operating systems. It both allows rather large files (which is heavily limited in FAT32), but can be both read and written in all important operating systems.

  • It's formatted FAT, because I use Mac at home and Linux at work and FAT is the only format that can be written and read in both Linux and Mac. It's happened to me with two disks of the Western Digital Brand. – Tulains Córdova Oct 27 '13 at 23:18
1

Agreed that it's a file system issue, but if the Mac was able to read and write to it in the past, the file system isn't incompatible with the Mac.
The file system may be damaged to the point where the Mac cannot decipher it anymore, but the Linux machine is more able to work around the damage. The sudden disconnection is also a symptom that the file system is damaged.
Which file system do you use on these disks?

  • The disks are formatted FAT, since that format allows interoperability with Macs, Linux boxes and Windows machines. – Tulains Córdova Sep 7 '14 at 5:35
1

This could be an issue with corruption of the file system/directory structure on the disk.

A utility like Disk Warrior may be able to help you resurrect the directory structure and recover the files.
However, given that this is your "backup" drive I would be concerned that the disk has become unreliable and would seek a new backup repository (as you mentioned buying a new disk, this is a good idea.)

Can you recover the files under Linux? If so this may be a cheaper alternative to consider. Finding a way to back them up somewhere else in order to be able to test the disk or relocate the files to a new backup disk should be the first priority.

If you primarily are just trying to use the files under Mac, then HFS+ (Journaled) is the best choice since it is more robust than something like exFAT. ext2 under linux would be an alternative as there are some solutions to read/write this filesystem under Mac as well.

So:

  1. Try a utility like DiskWarrior to recover/rebuild the disk filesystem. Alternatively recover the files under Linux if you can read them from there.
  2. Get a new disk to use as a new/second backup disk
  3. After copying/recover the original files you may want to reformat and test the original disk with something like a surface scan (TechTool can do this but is expensive, Scannersz Lite is a possible alternative.)

Unfortunately a Verify/Repair under Disk Utility is not that thorough so it will not fully test the drive like you need.

Here's an article on three popular disk tools in OS X http://www.peachpit.com/articles/article.aspx?p=1620209

  • Any disk will have a chance to fail over time and external disks are (usually) given harsher conditions. That is not to suggest they can't be used for backup but if the data is really critical it's not unwise to keep redundant copies of those backups.

  • No one particular Brand/Model will guarantee this doesn't happen again. You can check the different warranties available which suggests the manufacturer's belief in the reliability of a drive.

  • Some disks have 5 year warranties, 3 year or only 1 year. Determine what reliability/price ratio you want to pay for the data you are backing up. Also a refurbished drive will usually only have a 6 month warranty and wouldn't be recommended.

good luck!

  • Disk is OK. Linux mounts it with no problem and reads and writes to it. It's formatted FAT, because I use Mac at home and Linux at work and FAT is the only format that can be written and read in both Linux and Mac. It's happened to me with two disks of the Western Digital Brand. – Tulains Córdova Oct 27 '13 at 23:17
  • 1
    As I mentioned earlier, the fact that Linux can mount the disk does not mean the disk is OK. It just means Linux ignores or works around the errors. FAT is not the most robust filesystem, in fact all of the external disks I've had with FAT would fail at some point. Reformatting is then your best bet. – Hobbes Oct 28 '13 at 8:00
  • Agreed. At a minimum I would try to backup the files to another medium and reformat the disk. Try [cgsecurity.org/wiki/TestDisk] if you like... Otherwise trying something like the Disk Utility's ability to 'Zero out' all of the data on the disk might give you some clue if the disk is still good. After copying the data off the drive and formatting you can use the "Security Options" under Erase and see if it can write to the entire disk, if this process takes an exceptionally long time it's likely there is some damage to the disk. WD is good but try Seagate, Toshiba or Hitachi – Brian Lamb Oct 29 '13 at 6:04
1

I had the same problem. The HDD is NTFS, a 2TB WD MyPassport. I was using it between a PC and a mac for a few months (just got a mac), and this last time I plugged it in to the iMac, it wouldn't mount, including from right clicking on it... I ejected it and unplugged it then I plugged it in a PC. The PC was able to read it just fine. I stopped the drive (safely remove hardware) in windows and then disconnected it. I took it right over to the iMac and now mavericks sees it without a problem.

0

If a disk check is running in a background on a large drive, it will appear as stuck. You can just kill the pid and see if it mounts correctly:

ps aux | grep disk3

this reported a fsck_hfs -y on disk 3, consuming either a lot of CPU as well as keeping the drive like as locked.

killed the related PID

-1

I had the same issue, and i found the solution

if nothing worked for you , e.g.

  • safe mode unmount
  • disk repair
  • SMC reset etc.

then this video might help you:

  • Welcome to Ask Different! We ask you attempt to summarize content contained in links, both for ease of reading and in case the original goes down. Can you add relevant portions in the body of your post? – JMY1000 May 1 '17 at 20:44
-2

on disk utility.....just right click your hardrive then mount....it will mount....but if you mount it at the top it will fail.....

  • What do you mean with "mount it at the top" ? Please rephrase. – Tulains Córdova Feb 12 '14 at 10:17
  • Hi welcome to AskDifferent, I find if a question is worth answering it is worth upvoting. Also some instructions and a link may get you more upvotes. Please take the time to read the Answer and Question section of the help page. – Deesbek Feb 12 '14 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .