9

I switched from a Logitech keyboard to a Mac external keyboard on my macbook pro with Catalina MacOS. Every time I hit capitol M it types MZ. It could be the case that the keyboard is malfunctioning, but before I replace it I thought of trying to re-identify the keyboard and see if it helps.

MacOS user guide says this:

  1. On your Mac, choose Apple menu > System Preferences, then click Keyboard.
  2. Click Change Keyboard Type, then follow the onscreen instructions.

However I could not find Change Keyboard Type in that interface - see screenshot below. I also tried this sudo command but it didn't work.

How I could force a keyboard re-identification?

enter image description here

6
  • It’s hard to imagine any kind of wrong identification that would cause the problem you describe. Commented Jan 16, 2020 at 23:31
  • Strange, maybe because it's an Apple keyboard? Have you tried deleting /Library/Preferences/com.apple.keyboardtype.plist and restarting? What about just adding another input source in the Input Sources tab and selecting it?
    – JMY1000
    Commented Jan 17, 2020 at 8:27
  • Also I agree with @TomGewecke, this sounds like a hardware failure, not a software issue. Which Apple keyboard exactly is it you're using?
    – JMY1000
    Commented Jan 17, 2020 at 8:27
  • I have had a case where an apple keyboard would behave exactly like that after coffee was poured over the keys...
    – X_841
    Commented Jan 17, 2020 at 9:37
  • Can you try using this keyboard on any other machine? A hardware issue wouldn't disappear when changing system
    – X_841
    Commented Jan 17, 2020 at 9:38

3 Answers 3

7

I had the issue where I could not find Change Keyboard Type in that interface after migrating to new Mac with Big Sur and wanted to force keyboard re-identification.

Deleting /Library/Preferences/com.apple.keyboardtype.plist (as suggested above by JMY1000) and rebooting solved it. After the reboot the system ran the keyboard setup again and I could set the correct type.

2
  • When you say "same issue", did you actually get two letters instead of one when you pressed the M (or any other) key?? If so, please put that specific info in your answer too. If not, you need to tell exactly what your problem was. Commented Mar 6, 2021 at 4:48
  • Oh, I'm sorry, no I did not get the two letters instead of one. I was referring to the ”I could not find Change Keyboard Type in that interface” part and how to solve the ”force keyboard re-identification” part.
    – Adrian B
    Commented Mar 7, 2021 at 7:27
2

To force keyboard re-identification without deleting /Library/Preferences/com.apple.keyboardtype.plist and restarting, you can re-trigger the KeyboardSetupAssistant from System/Library - /System/Library/CoreServices/KeyboardSetupAssistant.app

Using Finder:

  1. Menu -> Go -> Go to folder (or Shift + CMD + G)
  2. Input the path: /System/Library/CoreServices
  3. Find and tap on KeyboardSetupAssistant

This have worked on macOS Ventura 13.3.1 for me

4
  • I tried this today (on Ventura 13.3.1) but when I launched the KeyboardSetupAssistant.app nothing happened. I had to fall back to the deletion and reboot again.
    – Adrian B
    Commented May 14, 2023 at 19:07
  • I'm sorry, it still works for me. A window popups and says: "Keyboard Setup Assistant", "Your Logitech device cannot be identified..."
    – kidroca
    Commented May 17, 2023 at 7:11
  • 1
    This work as today MacOS Ventura and M1 chip (I know is not relevant, but just in case someone finds it useful)
    – d70rr3s
    Commented Jun 20, 2023 at 8:53
  • ... same here (nothing happens from Finder) and when trying to run it from command line it crashes with "trace trap"
    – silverdr
    Commented Nov 8, 2023 at 10:23
0

Officially, only other external keyboards appear to change the keyboard type, 'Magic Keyboard' for Apple , The keyboard type is recognizable, so it won't appear .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .