0

I just ordered a new external Keyboard.The Logitech G915. After connecting it to my Mac, the first thing I did was to change the modifier keys (CMD and OPTION), since it has a windows layout. (I have a gut feel, that this messed with the keyboardtype plist, but this is unconfirmed.)

Now to the issue: I soon noticed that the key in the bottom left corner "</>" was recognised as "^/°". This means that my Mac thinks I am using an ANSI Keyboard (US layout). However I am in fact using ISO. That of course is a real bummer. I noticed this behaviour already some years ago when I performed a Major OS upgrade. (can not remember which one) Back then everything was working fine but after the upgrade it could not recognise my keyboard anymore. So it is clearly a MacOS bug that is troubling us here.

I tried multiple suggestions that I found on the internet and was eventually able to solve it. Not sure what exactly did the trick but I will let you know what i did.

2
  • Just added the actual answer as an answer below.
    – Thinkr
    Commented Nov 25, 2023 at 7:46
  • This problem has been covered quite a few times already in this forum and elsewhere. One recommendation from the Apple community is at discussions.apple.com/docs/DOC-250007848 Commented Nov 25, 2023 at 18:34

2 Answers 2

1

Ran into the same problem on my Mac Mini M2 using Sonoma, I've got a Corsair keyboard and a Razer mouse connected to it, and it refused to actually change to the ISO layout for the keyboard. Based on the setup assistant saying "Your Razer device", I'm guessing it's wrongly trying to set the keyboard type for my mouse instead.

What worked for me is this:

  • Enable keyboard navigation if it is not already (you'll need it later) Keyboard navigation
  • Run sudo rm /Library/Preferences/com.apple.keyboardtype.plist
  • Power off the Mac and disconnect my mouse dock (the wireless adapter sits in the dock)
  • Power it on again, sign in, and open the system settings
  • Now work your way down to "Keyboard" on the left using the down key, then use the tab key to navigate down to the "Change Keyboard Type..." button then press space to open it. Keyboard type
  • For me the "Quit" button had the focus by default, so press the tab key once to change to "Continue" and press space. Follow the instructions from here. enter image description here
  • Once at the "Select the Keyboard Type" screen, verify that it's the correct type and press Enter to confirm. enter image description here
  • After this, I connected my mouse again and things worked as expected.

If everything now behaves like you expect, you can now disable the "Keyboard navigation" option if you prefer.

Side note: The most accurate premade keyboard layout for me was the "Logitech Norwegian" one that's bundled with Ukulele

1
  • I have hp wireless keyboard set and it worked, i no longer need to use Karabiner. thank you so much.
    – forsaken
    Commented Feb 27 at 20:01
0

Steps performed to resolve the issue:

  • Reset the modifier keys in System Settings to default (there were multiple because my keyboard can connect in 3 different ways)
  • tried to run the "Change Keyboard Type" wizard a few times without success enter image description here
  • run sudo rm /Library/Preferences/com.apple.keyboardtype.plist in terminal AND REBOOT
  • Install Karabiner-Elements (because it was still not working)
  • Launched the tool and went to "Virtual Keyboard" to set everything to ISO. THEN REBOOT
  • Fiddled around with the settings because of CMD + OPTION keys. (this tool creates a seperate keyboard that also shows up in system settings > modifier keys)
  • I did not like the tool so i unintalled it again (there is an uninstaller option inside the app) AND REBOOT

So now here comes the interesting part:

After uninstalling Karabiner-Elements AND rebooting the mac one more time, they keyboard setup wizard showed up again. I Continued to setup as usual and this time it actually worked!!! It got correctly recognised as ISO. After that i was able to change the modifier keys in system settings and everything is perfect now. I then connected the keyboard via the other 2 options (there is usb, bluetooth and lightspeed), and each time the wizard appeared and recognised it correctly.

So that's it. I am not sure what exactly solved the issue, because before i installed karabine-elements I resetted and rebooted quite a few times. I hope this will be helpful to anybody else. Enjoy

1
  • @TomGewecke Thanks, but I think this would be more helpful if addressed to the OP directly. :)
    – Thinkr
    Commented Nov 25, 2023 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .