1

Given Dark Mode can really enhance battery life, I'm keen to implement it.

Although all my other IOS/IPADOS 13.3 Apps seem to respect the "System Preferences" > "Display & Brightness" > "Appearance" > "Dark", I noticed gMail didn't for some reason.

Google offered this guidance for configuring Dark Mode:

For iOS 13:

  1. On your iPhone or iPad, open the Gmail app
  2. In the top left, tap Menu Menu and then Settings.
  3. Tap Theme.
  4. Choose Light, Dark or System default.

Since the menu item "Theme" was missing in my gMail settings, I gave up trying to configure Dark Mode- wasn't possible to follow the instructions to achieve a correct result.

My gMail settings look as follows:

gMail Settings Dialogue: Dark Mode BROKEN

By chance I noticed my Wife was using Dark Mode in gMail. Given we have the same iPad Pros (2019 12.9"), I decided to try to implement Dark Mode again.

Doing some comparative analysis, I investigated how our iPad configurations varied.

Below are my Wife's gMail settings. When you compare the below graphic of her correct settings with mine in the previous graphic, remark (2) things:

  • There is now a menu item titled "Theme" which is not present in my settings

  • Version Number: Both the Broken AND Working Dark Modes use same gMail version

gMail Settings Dialogue: Dark Mode WORKING

How else did the two iPads vary?

  • My iPad uses both gSuite and a personal gMail accounts

  • My Wife's iPad only has a personal gMail account.

Remarking this difference, I made the following changes to my iPad to mirror the working iPad (my Wife's):

  • Deleted the gSuite gMail account to exclude possibility there was a Domain permissions issue. This did not resolve the broken Dark Mode issue

  • Deleted and reinstalled gMail itself. This too failed to resolve the fault

So both iPad Pro's use the same versions of gMail, but the iPad with working Dark Mode HAS the "Theme" menu in settings, the other with broken Dark Mode does NOT.

  • Is the gmail app updated? – Thorbjørn Ravn Andersen Jan 12 at 20:37
  • Yup- no updates are queued for gMail. Besides, even if there were, since my Wife's iPad which has working Dark Mode and my own which doesn't, since the use the same version of iPadOS, version I'd imagine should be an issue. After all, here is working and mine isn't and we're on the same version. – F1Linux Jan 12 at 20:43
  • Have you tried logging into your wife’s account on your iPad and/or signing into yours on hers? My assumption is that this feature is being gradually rolled out, and her account got it earlier than yours. – JBallin Jan 13 at 0:53
1

The dark mode deployment in Gmail started in September 2019, and as Google states it on the G Suite Updates Blog "To optimize the user experience, we're rolling it out slowly, and will post an update here when that rollout is complete." It is linked to your Gmail account and until Google activates it for you, you won't be able to see it.

I had the same problem and adding my second Gmail account solved it. You should try to temporarily login with your wife's Gmail account on your iPad and activate the Dark Mode.

| improve this answer | |
1

UPDATE:

Was surprised to see Dark Mode magically working on my iPhone's gMail. I had not fiddled with anything lately, but voila, there it was. However, when I checked my iPads, these did NOT have Dark Mode enabled. Checked the versions on the iPads and these had the same one as the iPhone: v.6.0.200412. So what was different? I rebooted the iPhone recently, but NOT my iPads.

Upon reboot of the iPads, Dark Mode was now working on gMail on all my devices.

How to get Dark Mode working: (3) Steps

  1. Set Dark Mode as the system-wide preference in: "System Preferences" > "Display & Brightness" > "Appearance" > "Dark"
  2. As @Lulucmy rightly noted in his answer, Google must enable the feature on their side or Dark Mode ain't happening for you.
  3. Reboot the device periodically: Google will not notify you they are enabling Dark Mode. I had periodically closed gMail from time to time since I last updated it 01 May, and Dark Mode was still not working in gMail. Only when I rebooted my iPhone did the change seem to be effective.

So Dark Mode will respect the global System Preference, but only where Google has enabled it on their side. So I guess patience is also required for those eager to extend their battery life using gMail in Dark Mode.

Anyhoo, my observations on how my own Dark Mode Hell was resolved. Hope this saves others cycles trying to resolve the issue-

| improve this answer | |
-1

Google confirmed some time back, this is a server side configuration. If you are not seeing the option, its not rolled out to you yet. Though I don’t know the reason why it has been done. My case is the same.

| improve this answer | |
  • 2
    A link to that confirmation by Google would make this answer much better – Allan Jan 13 at 7:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .