I'm using the 2020 Intel MacBook Pro and I'm facing the following problem.

The Auto-Dark-Mode of MacOS is not as stable as iOS or iPadOS. If I'm using a single app in foreground (probably Safari) and it's sunset time, the Auto-Dark-Mode works as expected, but when I'm working on a project so I have 5-6 apps opened together in foreground, Auto-Dark-Mode fails but the wallpaper goes to Dark-Mode (but the the apps doesn't), and it happened right now while I'm writing this post.

Note: When I toggle Dark-Mode manually after Auto-Dark-Mode fails, they goes to Dark-Mode as expected (if they have light mode, for example some apps like VS-Code don’t change their theme with system). I’ve faced this issue on Catalina as well.

How can I resolve the issue?

  • I personally say in dark mode, but what program are you using that doesn't seem to change? Is it just Safari or another program? Does that program support Dark Mode? Does the Safari site support Dark Mode as well?
    – ErniePC12
    Commented Feb 7, 2021 at 14:34
  • When It fails, It does for all the programs. Then I have to manually go to System Preferences and set Theme to Light/Dark then to Auto Again, then It updates.
    – user405784
    Commented Feb 7, 2021 at 14:35
  • "Please tell me if my problem is a common one" doesn't solve a practical problem. Also, are you sure these 5-6 apps support auto-switching at all?
    – nohillside
    Commented Feb 7, 2021 at 14:36
  • If you were to quit thee applications and relaunch them after the dark mode turns on, what happens?
    – ErniePC12
    Commented Feb 7, 2021 at 14:37
  • @ErniePC12 I never tried that, because that procedure has more steps than simply updating the settings in System Preferences.
    – user405784
    Commented Feb 7, 2021 at 14:39

1 Answer 1


The answer is quite trivial: because macOS is buggy even in such core features.

A workaround I use when I face similar glitch in the evening: going to system settings, not forcing dark mode, but "forcing" light mode instead, then returning setting back to "Auto". Switches immediately. But more likely the next evening you'll have to do it again. Why? — Because macOS is buggy even in such core features.

You must log in to answer this question.