3

A lot of my notes have links in them, but I don't want them to automatically be changed into hyperlinks after pressing space or enter.

I'd like them to remain as plain text without having to manually remove the link by right-clicking.

How can I turn this feature off? I'm guessing there might be a way to do this in terminal but I'm not sure where to start.

7

Here is the solution:

  1. Open your note.
  2. Go to Edit then Substitutions and uncheck Smart Links

It will resolve your open query.

Also, uncheck Smart Copy/Paste to be more precise and if necessary.

| improve this answer | |
  • Apple should have put this in Preferences... – alizaliz May 27 at 5:21
1

For an "at the end of the task" solution, you can Select All, Go to Format menu, font item and choose "Remove Style". You can also bind a shortcut for the same in System Preferences → Keyboard → Shortcuts, under Application shortcuts tab.

enter image description here

Another slightly clumsy approach is to select the link and copy-paste it without style.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .