1

I've recently started having issues with my Mac. I'd create a screenshot on my Macbook, which would land in my iCloud/Desktop folder (I don't know why this changed, but right now instead of saving on my Desktop only it saves in iCloud/Desktop only). The files are saved as "Screenshot 2020-01-14 at 11.08.14.png".

Unfortunately I can't delete these files. Trying to delete them gives me the same sound as if the action was successful, but they still remain. I've had to manually log in to my iCloud account and delete them from there. I tried clicking on "Remove Download" but it doesn't do anything.

I'm on MacOS Catalina 10.15.1 (19B88)

  • 1
    1 Is it only for screenshots? Try manually adding files and removing them. 2 Is the screenshot in use by some other activity like preview editor etc? – ankii Jan 14 at 13:03
  • It's for any file that has space in it. I just run touch "foo bar Something something" in my Desktop folder and it created a file I can't delete via finder. I need to remove it from terminal. I don't know where iCloud/Desktop folder though, so can't do the same for that one. – eithed Jan 14 at 13:20
  • I think it's Mobile Documents in ~/Library, but it might not be fruitful. Search the site for the same to see previous attempts to get things out of it. – ankii Jan 14 at 13:25
0

I don't know why this changed, but right now instead of saving on my Desktop only it saves in iCloud/Desktop only

Hit cmd + shift + 5 > Options and change the screenshot save location. I cannot take a screenshot of a screenshot window, but it's easy.

.. my iCloud/Desktop folder ..

You might have turned on iCloud for Desktop and Documents. Check in the System Preferences → iCloud options. Turn it off, and all your documents will get downloaded to an iCloud Archive folder directly under Users/me/. Then you can move all those content to the original, local Desktop folder.

If you don't like it, just change the screenshot save folder to a non-iCloud synced folder.

  • In options it displays Desktop. They are saved to iCloud/Desktop though and not to Desktop (if I'll go to terminal and go to ~/Desktop/ they're not there. I've not turned anything - I had iPhone, but have not used it for 2 years (still have that account though) – eithed Jan 14 at 13:25
  • i.stack.imgur.com/2MCO1.png this is what i was taking about in the last line – ankii Jan 14 at 13:27
  • Yes, it's turned on in there. I have to disable it for the screenshots not to be saved on iCloud. Ideally I'd like my screenshots saved to my local Desktop, not iCloud/Desktop. My settings for screenshot utility is like this: imgur.com/a/1U5x8CZ – eithed Jan 14 at 13:33
  • 1If you want, disable it. Also see my edited answer. 2 If you want them to not go to iCloud, then you got to turn it off. – ankii Jan 14 at 13:39
  • Thanks! Any ideas on how to delete a file with space in the name, from within finder? – eithed Jan 16 at 12:49
-1

Looks to me like two issues:

  • Why do you have two Desktop folders? On my machine - and I strongly assume, this is how its supposed to be - I have one Dektop folder, which is located in iCloud. Thats also where the screenshots for example go.
  • Trying to delete them

Where did you delete them? Also in the trash can?

"Remove Download" only removes the item from your local machine, freeing disk space, but keeping them available on iCloud.

EDIT: As far as I know, there is macOS 15.2 available. Install it (after you backup your files).

  • I don't know - on my machine it's two folders. Trying to delete them via Finder. Yup, I'd think that Remove Download should prevent them from displaying, but they still are. – eithed Jan 14 at 13:22
  • No, they will still be displayed. Yet, the actual file is not stored on the local machine anymore. Therefore, when trying to access it later, you need to have an internet connection as Finder will download it again. I suggest you merge your Desktop folders into one on iCloud. – X_841 Jan 14 at 13:25
  • Can you provide how can I do that? – eithed Jan 14 at 13:26
  • By merging I mean copying your files from your local Desktop folder into the iCloud/Desktop folder and then deleting the local folder. – X_841 Jan 14 at 13:30
  • You cannot delete local Desktop folder. Also, from now on, use @ to ping people in comments here. One person per comment. "On my machine - and I strongly assume, this is how its supposed to be - I have one Dektop folder, which is located in iCloud." ==> -1. – ankii Jan 14 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .