1

I just installed Catalina (10.15.2). I can no longer launch many apps with Spotlight: Terminal.app, Mail.app, Calendar.app, the dictionary, etc.

Some apps do launch, like Safari and Numbers.

It appears that there are now two Applications areas, and it seems that Spotlight doesn't index any that are in the /System/Applications area.

I have tried adding and removing the /System/Applications directory from the privacy settings of Spotlight (apparently supposed to cause Spotlight to re-index an area), rebooting, clearing PRAM, and the following commands:

sudo mdutil -E /
sudo mdutil -E /System
sudo mdutil -E /System/Applications

All of which has been to no avail.

I haven't been able to find similar complaints online. Is this just affecting me? Or is this a general problem with Catalina?

If just me, what else can I try to diagnose or solve this?

Edit (update):

OK, I tried the following sequence, suggested in the comments below:

sudo mdutil -i off -a
sudo mdutil -i on -a

Then I repeated it and removed a Spotlight file while it was off (still without success):

sudo mdutil -i off -a
sudo rm -fr /System/Volumes/Data/.Spotlight-V100
sudo mdutil -i on -a

Can anyone comment if Spotlight is working for them on Catalina to launch apps under /System/Applications (e.g., Terminal.app)? I still don't know if this is my problem or a general Catalina problem.

9
  • More context on "It appears that there are now two Applications areas," here in these two questions: apple.stackexchange.com/questions/linked/372349 – anki Dec 26 '19 at 16:45
  • /Systems/Applications is said to be on a read-only filesystem, if that's the case, and if it's to be indexed, the index would have to live on /System/Volumes/Data. Can Spotlight do that? Or is it not possible to index a read-only filesystem? (I still don't know if I'm the only one, or one of the few, with this problem or if everyone has it.) – user1984717 Dec 26 '19 at 17:26
  • Have you tried rebuilding entire spotlight index. Plug in power, if you want. Also edit the question to add your query you mentioned here. I cannot help further. – anki Dec 26 '19 at 17:28
  • @ankii I've tried sudo mdutil -E /, which I thought was supposed to rebuild the index. Is there another technique? – user1984717 Dec 26 '19 at 17:43
  • 1
    Though the Spotlight DB for ro / lives on the rw volume (Data), the datastore /System/Volumes/Data/.Spotlight-V100 is responsible for Data only. The datastore for ro / lives at /private/var/db/Spotlight-V100/Boot-Volume/Store-V2/[some_UUID]/. (sudo mdutil -L / vs. sudo mdutil -L /System/Volumes/Data). – klanomath Dec 27 '19 at 13:44
2

This is a rare situation, but I’ve had great success making a new volume sharing the same APFS container and reinstalling a clean OS in a new volume to validate it’s not your disk that’s failing(failed). It’s not at all unique to Catalina and Catalina works great for spotlight in hundreds of machines we have. We’re seeing fewer spotlight issues compared to older OS in fact.


Back to what you can do - installing a new OS to the same container (to test). I would back up all your important filed before poking anymore, just in case. Once you have that system set up you can let spotlight run on the new OS and convince yourself it’s just that you have corrupt data on the old volume.

Once you know you have a working system, you can run some apps or just run Migration Assistant to bring the files over. If you lack space to have two copies of everything - boot to the old systems and clean / run a Time Machine backup and restore from there (or just erase and install if you already have a backup) knowing things will be fixed.

The commands you list are nice if they work once, but running them several times rarely patches up a system that’s broken in my experience so the sooner you can delete / walk away from the corrupt data / files / filesystem, the better.

If you really need to isolate the failure, I would run mddiagnose and review the files - it’s a ton of work the first 5 to 10 times you try to understand all the diagnostic files - like finding a needle in a haystack, but most failures can be identified from the diagnostic output.

1
  • 1
    I wasn't sure how to do quite what you suggested, but I restored from a backup made just prior to installation and re-installed Catalina. It seems to be fine now. – user1984717 Dec 28 '19 at 13:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .