1

This is on a 2019 MBP running Catalina 10.15.7. I also have a 2012 Mac mini running the same OS, and that has no problems indexing all the apps.

I should point out that I've tried all of these:

  • Added the system drive to "Privacy" in Spotlight and then removed it
  • Revealed the hidden Spotlight folder and deleted it
  • Run sudo mdutil -Ea /

Nothing's worked. Where can I go from here?

To reiterate, it indexes all my third-party apps with no issues. It's only the built-in standard macOS apps that it's refusing to see.

2
  • If you found an answer to your own question, please post it as an answer post below and accept it.
    – nohillside
    May 17 at 5:38
  • What worked for me was sudo mdutil -i on -E /, which will erase all Spotlight indexes in / and enable indexing. Could you try it and report back?
    – jaume
    May 17 at 6:09
0

Back in 2019 I had a client whose Spotlight wouldn't index fully. We ran Etre Check on his machine and got back some info from mds, reporting that mdimporter was crashing, and it gave us a file id.

I had him open up a terminal and put in sudo mdutil -t <number>. It came back with a path to an email. I had him open up that email (with open <path>), he reviewed the email, decided he didn't need it and deleted it.

IIRC we had to repeat the process multiple times until mdimporter stopped choking on his files. Not sure what kind of bug we tripped, but after deleting maybe file of his files, his system indexed properly.

Start here and see if this shows anything related to Spotlight, mds, or mdimport.

Etre Check

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .