Ok, I’m in a bit of a pickle here. I wanted to install the latest macOS 10.15.1 update today and was initially told that I needed to “free up more space”, since the upgrade expects about 19 GB of free space. Ok, I did that and the upgrade installer launched (after a restart). Unfortunately, it told me (again) that I do not have enough free disk space and I was supposed to restart the machine to free up more space. Ok, I tried that but I am now stuck on the login screen. Every time I login the loading bar progresses to about 50% and the screen just turns black.

I went to the Apple store today and they mentioned I should just try to re-install macOS.

I can see the answers suggested here on how to accomplish that: Mac stuck in restart cycle after failed macOS Catalina update

However, when trying to recover / reinstall macOS - the installer also tells me - you don’t have enough free space to reinstall macOS.

So I am left wondering - why is there no option (e.g. in Disk Utility) to selectively free up some space. It seems the only options I have are: 1. create a full disk image (through Disk Utility) 2. Wipe the disk 3. re-install macOS

It would be great if I could somehow launch a terminal or something similar to free up some space. With the latest macOS, is there still a way to launch into “terminal login mode” - I believe this used to be possible.

Btw. I did try “safe boot” and all the rest without success.

Any help on how to free up just a bit of space so I can launch the macOS installer would be much appreciated!

  • Have you tried restoring from time machine, apple.stackexchange.com/a/373065/107414? It shouldn't produce any problems. Nov 5, 2019 at 19:28
  • Thanks, but I am not using time machine, since this is a work laptop and we don’t use time machine at work. I am also not worried about loosing data (all my relevant work is in appropriate cloud storage). However, I am trying to not have to setup my work environment again from scratch, which tends to include a lot of files that time machine doesn’t like to backup anyway.
    – Chris
    Nov 5, 2019 at 19:37
  • By not using Time Machine you mean that it is disabled? Because if it's enabled then you have multiple snapshots of data by APFS. And I wonder how reinstalling macOS related to your answer below, e.g. why do you need to enter Recovery mode to reinstall your system? I can assume that it might be useful for removing files using the Terminal, which won't help with free space with APFS. Nov 5, 2019 at 20:09

2 Answers 2


Ok, so I found this: https://support.apple.com/en-us/HT201573

Single-user mode

  1. Turn on your Mac, then immediately press and hold Command-R to start up from macOS Recovery.

  2. Select Disk Utility from the Utilities window, then click Continue.

  3. From the Disk Utility sidebar, select the volume that you're using, then choose File > Mount from the menu bar. (If the volume is already mounted, this option is dimmed.) Then enter your administrator password when prompted.

  4. Quit Disk Utility.

  5. Choose Terminal from the Utilities menu in the menu bar.

  6. You can now enter UNIX commands. When done, choose Apple () menu > Restart.

The key is step number 4 & 5, which allowed me to launch a terminal window while the correct volumes were mounted. I am currently re-installing macOS.


I was stuck with 2 partitions - "SSD" and "SSD - Data". Deleting "SSD" allowed me enough free space to reinstall from recovery without losing all my data.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .