2

I've been trying to partition my harddrive to have ~50 gb of unallocated space (right now there's one partition with the operating system on it, so I would like to have that plus the free space). This is for Windows if that matters, and is independent of Boot Camp.

I have more than enough room.I managed to do it once earlier today, but now whenever I try to create the free space partition it automatically formats it to the journaled mac os. I go to disk utility, click on my harddrive, partition, then the plus at the bottom and select free space, resize to 50 GB and apply. and it formats it. Can anyone tell me what is going on?

To clarify: when I try to create a partition of "free space" using disk utility, it is formatted automatically and against my will to HFS+ Journaled. Is there any reason this would be happening? Is there anyway to force a "free space" partition to be created

Sorry for the poor pictures. also please ignore the separate NTFS partition. I am still trying to install Windows while I am waiting for answers, so it was intentionally added and does not affect my problem.

EDIT:

The partition at index 4 was created using the terminal (but it couldve been created using the plus minus in disk utility), and i have no problems whatsoever creating non-free space partitions with either of these methods. When I tried to install windows to that partition at index 4, I received an error saying that the selected partition is of MBR and i need GPT, which indicates to me some sort of hybrid mode where mac reads gpt and windows reads mbr.

I got around this error once by creating free space and partitioning/formating it within the windows installer. However I cant make that free space anymore, as i said before i cannot create a partition of format "free space" within disk utility. I tried dragging the hdd box within disk utility as mentioned and have posted the results. As you can see it does not show up as free space, or at least it does not show up in finder as a free space partition.

Specifically Id like to know what this step does or whats causing the problem, Remove the new HFS+ volume with gpt and its index number found above: gpt remove -i 4 disk0

Sorry for only two pictures, apparently I cant post more than two links

System specs: Macbook Pro 15 (mid 2010), Yosemite 10.10.5

enter image description here

enter image description here

  • I don't know what you're asking. Can you clarify what the issue is? – At0mic Oct 20 '15 at 4:12
  • Please add your system version, a screenshot of Disk Utility and the output of sudo gpt -r show /dev/disk0 entered in Terminal.app – klanomath Oct 20 '15 at 4:59
1

First I have to explain the gpt result:

The partition with index 1 is your EFI partition. The partitions with index 2 and 3 are your main OS X volume named Macintosh HD (also visible in the second screenshot) and your Recovery HD. The partition with the index 4 is your NTFS volume WinB (also visible in the second screenshot).

Trying to add a new partition (by using the +-button) or to resize Macintosh HD (by using the handle) with Disk Utility will downsize partition 2 and move partition 3 to the new end of partition 2.

Since adding a new partition with the +-button doesn't work properly for you, you have two options:

  • use the handle and resize Macintosh HD. This should create unallocated free space
  • or use the +-button and create a new volume. Apparently it will be formatted as a HFS+ Journaled volume.

    • Then boot to Internet Recovery Mode and open Terminal.
    • Enter diskutil list and gpt -r show /dev/disk0.
    • Unmount your main disk with diskutil umountDisk /dev/disk0.
    • Remove the new HFS+ volume with gpt and its index number found above:
      gpt remove -i 4 disk0
    • Enter exit and quit Terminal
    • Reboot

This might break Boot Camp as stated in Disk Utility and is not recommended if Windows boots in MBR-mode. So backup your Mac (including the Bootcamp partition) first.


I tested this with a spare MacBook Air (Mid 2013 with a 250 GB SSD) and a vanilla Yosemite after installing Windows 8.1 R1. Regardless what I did, I had no problem to boot from either Windows 8.1 or OS X. Windows 8.1 seems to be booted in EFI-mode though.

Since you have an older Mac, Windows will probably be booted in hybrid MBR-mode. Adding a fourth partition (at position 3) will break bootability of the last one because only three partitions (and the EFI partition) are allowed.

  • Ok Im not sure this will fix my problem, but please correct me if Im wrong. Please see my edit – mike Oct 20 '15 at 16:25
  • @mike What's the purpose of the additional volume? – klanomath Oct 20 '15 at 16:27
1

I got my overprovisioning working by deleting the inadvertently created "untitled" partition:

diskutil eraseVolume free n disk0s4

This was the hint diskutil gave after I tried to join the resized unwanted partition to the APFS container on the disk.

diskutil mergePartition APFS newname disk0s3 disk0s4

Now it is working, apparently, and stays this way over reboots. Interesting OS... I am sort of new to macs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .