1

I had deleted the macOS and macOS recovery partitions many months ago to increase the capacity for the Bootcamp Windows. Now I want to reinstall macOS via a bootable USB, but on booting into it, it gets stuck in the spinning globe screen forever.

My internet speed is pretty fast, I get no issues on other devices though. I tried unallocating some space out of the Bootcamp partition for internet recovery to install, but to no avail. Because of this, I am not able to go to recovery and enable boot from external disk.

Any help would be appreciated. Thanks.

  • Internet Recovery installs to RAM not disk; so that's not your issue. Eternally spinning globe would indicate a bad net connection. – Tetsujin Sep 19 at 10:27
  • @Tetsujin My internet works fine and is high speed, I simultaneously check it on another laptop. So that doesn't seem to be an issue. Anything else I can check? – mohsinulhaq Sep 19 at 10:34
  • Wait for it to time out & see what error code you get. So long as the globe is spinning, it's trying to connect & download the recovery. You can do this even without any disk in the Mac, so that isn't as yet your issue. Use wired Ethernet if at all possible & absolutely avoid any WiFi connection with a portal, as it won't work. – Tetsujin Sep 19 at 10:37
  • @Tetsujin Yes, I had it connected to Ethernet for half an hour now. I will let you know if any error comes up. – mohsinulhaq Sep 19 at 10:57
1

You will surely get this to work once your download completes from Apple servers. Things are busy with iOS 14 release, it if you can’t get this over several hours, take your Mac to a new network.

Internet recovery needs you to connect to some main servers - unfiltered access with no firewalls which can be problematic in some countries and some networks.

Or have someone make you an installer if you trust them.

The only other option is hardware repair if your device doesn’t erase when you correctly follow arch of the erase install steps.

| improve this answer | |
  • I have waited for internet recovery to download for 6 hours now on a 100Mbps connection. It might very well be the network firewall issue, because pings to some of the hosts in your link are timing out. Anyway, you have mentioned using an installer as an alternative, but I found out that Macbooks with T2 chips have boot via external drive disabled by default. To remove that restriction, I need to go into the recovery mode. So I'm back to my original problem. Have I misunderstood this? Are there other ways to boot into my bootable USB? – mohsinulhaq Sep 19 at 16:26
  • No, you can always boot T2 chip to signed OS. You don’t need an internet connection if the installer is good and untampered with, correctly signed by Apple. To get that properly signed installer you need an open network. Catch-22. – bmike Sep 19 at 16:50
  • So do I need proper internet to run createinstallmedia for it to work? Or only when booting into the USB? Because it asks for internet access when booting into the USB as well. – mohsinulhaq Sep 19 at 20:09
  • I’ve not tried to run createinstall media offline. I know you need to be fully online to get the Install app. I’ve run the USB install totally offline so that works for me @mohsinulhaq – bmike Sep 19 at 20:22
  • But in the link for creating bootable USB, it says: A bootable installer doesn't download macOS from the Internet, but it does require the Internet to get information specific to your Mac model, such as firmware updates. If you need to connect to a Wi-Fi network, use the Wi-Fi menu in the menu bar. Is there any way to tell it to not use the internet when installing, like you did? – mohsinulhaq Sep 19 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .