I am trying to erase all data from my laptop and reinstall OS X before I trade in.

I erased all data on Macintosh HD but now when I go to reinstall OS X there is no hard drive appearing when prompted to select a hard drive to install OS X. I go back to disk utility and Macintosh HD is gone, it has been replaced with disk0s2 which is not mounted.

Here is a picture of my disk utility. I am not sure how to fix this issue so I can get OS X reinstalled.

enter image description here

Here are the results of running diskutil

diskutil screenshot

  • Silly question, but have you tried clicking the Mount button in Disk Utility? If it doesn't mount the disk, does it display an error message? Aug 15, 2019 at 20:00
  • Nothing happens when I click the mount button. Also, I ran "diskutil mount /dev/disk0s2" from terminal and received this message: "Volume on disk0s2 failed to mount." Aug 15, 2019 at 20:08
  • 2
    Can you select the parent of disk0s2 in Disk Utility and perform the erase again? I think I've had a similar problem in the past and re-erasing the disk solved it. Try the erase operation at least once more if it doesn't work first time. Aug 15, 2019 at 20:15
  • It's also worth trying to run First Aid on the parent if it will let you do that. Aug 15, 2019 at 20:18
  • 1
    Choose Mac OS Extended (Journaled). You can use "Macintosh HD" or any name of your choice. Aug 15, 2019 at 20:24

1 Answer 1


Select the parent of disk0s2 in Disk Utility and try the erase operation again, at least twice if it doesn't work first time. If that works, proceed with the reinstallation of OS X.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .