1

I had two disk paritions, (disk0s2 and disk0s4 that are roughly 300GB and 200GB respectively). I wanted to merge the smaller one with the larger one. I ran, in the following order:

  1. diskutil eraseVolume free n disk0s4
  2. diskutil mergePartitions JHFS+ Drive disk0s2 disk0s4

Now I see the following in my disk utility: enter image description here

Similar picture with diskutil list: enter image description here

I tried running first aid on all disks, but to no avail. Is there a way to point to the disk that there is more space than it thinks?

1 Answer 1

1

Try

diskutil erasevolume free n disk0s3
diskutil apfs resizecontainer disk0s2 0
2
  • That worked! Do you know what was the problem with OXRESERVED? I had Windows installed on the mac before. Jul 9, 2022 at 18:06
  • OXRESERVED is a temporary partition created by the Boot Camp Assistant. The partitions contains the files from the Windows ISO from Microsoft and the Windows Support Software (i.e. drivers) from Apple. The partitions is suppose to be removed after Windows is installed. For some reason, your Mac still had this partition. Jul 9, 2022 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .