0

I recently reinstalled my macOS from Catalina to High Sierra to try and install Windows 7/8, but I keep running into a problem: The startup disk does not have enough space to be partitioned. You must have at least 40 GB of free space available. Here is the startup disk:

and diskutil list:

   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         1000.0 GB  disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1000.0 GB  disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh SSD - Data    715.8 GB   disk1s1
   2:                APFS Volume Preboot                 119.9 MB   disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      2.1 GB     disk1s4
   5:                APFS Volume macOS High Sierra       107.6 GB   disk1s5

I tried the time machine solution, it didn't work, so I assume it's got something to do with me downgrading to High Sierra. Any help?

EDIT: I tried manually to create a partition via Disk Utility but it wouldn't let me, only a maximum of 28.5GB.

Just in case, I'm ready to erase the Macintosh SSD - Data Volume which I haven't erased when reinstalling macOS High Sierra, I have all the data backed up on my hard drive via time machine.

1 Answer 1

0

That 715.8 GB "Macintosh SSD - Data" looks to be a remnant of Catalina. Catalina creates a System disk and a Data disk and uses firmlinks to make them appear as one drive in Finder. But the System disk is read only.

Meanwhile your macOS High Sierra volume is using only that volume for everything.

I think if you delete the APFS Volume Macintosh SSD - Data 715.8 GB disk1s1 you'll have enough free space. You backed up your data right?

1
  • Yeah, I backed it up via time machine. Deleting the APFS volume did the trick, thanks.
    – Alexei Dom
    Jul 27, 2020 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .