8

Every time I get a text-message from a new number, I get this big, red message:

enter image description here

WARNING: Apple will never ask you to open Terminal or execute a command on your Mac, click a link, visit a website, send or change your credentials, send or reply to an e-mail or text message, call someone, receive a call, or download and run an application on your phone or your Mac. If such a message claims to be from Apple and asks you to write back or take any similar action, it is a phishing message designed to compromise your account. Do not reply and immediately tap below to report it. If you are unsure, stop and contact the IS&T HelpLine before doing anything else.

Notably, there's no where to ‘tap below’ under the message; and I have no idea what the “IS&T HelpLine” is.

How do I disable this? I'd almost think it were some sort of reverse-psychology phishing worm, because I'm very sure this isn't default iMessage behaviour … except that I can't think of a way that this behaviour benefits a hostile actor? -_-

10

Turns out that this is Apple internal messaging, intended for employees.

It appears that, if the machine has a directory named AppleInternal in the root directory, certain Apple-employee-specific features of the OS — including the above one — are silently enabled, without explanation.

enter image description here

I've no idea how this happened to my machine, but I rm -rf'd /AppleInternal, rebooted Messages.app, and the message has stopped appearing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .