10

I recently bought my first Mac, after having been impressed with my iPhone 7 Plus for the past year. On my iPhone I can send both iMessages and text messages by switching on the "Send as SMS" option in Settings.

On my Mac the Messages app works great, except for when I want to send a message to a non-Apple user (most of my friends are on Android). When I try do do this I get an error like the one below:

enter image description here

I feel like I looked everywhere in System Preferences, but cannot find a "Send as SMS" option. Surely this is possible? How?

  • Note that "Send as SMS" does not do what you think it does; what it does is enable fallback to SMS in case an iMessage couldn't be delivered for a while. I personally recommend leaving it disabled, as it can cause conversations with people who have only intermittent connectivity to the Internet to jump back and forth between iMessage and SMS. Regardless of the setting of that switch, SMS is fully supported by the iPhone. – Alex Nov 2 '17 at 16:53
13

Yes, it is possible! However, you do need to set things up first.

Follow these steps:

  1. Sign into iCloud on your Mac and iPhone using the same Apple ID
  2. On your Mac open the Messages app
  3. On your iPhone go to Settings > Messages > Text Messages Forwarding
  4. You should now see your Mac listed - tap on the toggle to enable it.
  5. You’ll see a prompt asking you to enter the code shown on your Mac.
  6. Enter the code

Now when you add a non-iPhone mobile number into Messages on the Mac it will be highlighted in green - this is an indicator that you are sending a text message and not an iMessage.

NOTE: As all text messages sent from your Mac are now forwarded via your iPhone, they will count towards any associated costs for your mobile plan (if any).

  • You must also ensure that in the iPhone's Settings > Messages > Send & Receive, your Apple ID email address is listed, as well as your phone number. This will ensure that your message history is synced between iPhone and Mac, as well as forwarding text messages. Note that if your iPhone says only "SMS Message forwarding" in settings, you have not yet done the Send & Receive setting step. This article has more details. – RichVel Nov 5 '17 at 9:41
  • When I try to enable "Text Message Forwarding" in my phone's Messages settings, I see the "Enter the code shown on your Mac" message but no code is ever shown on my Mac. Any ideas? – cayblood Dec 26 '17 at 22:17
  • @cayblood You have probably already linked this Mac with your iPhone so no code is shown. – Artem M Jun 26 '18 at 12:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .