1

Whenever I open up FaceTime/Photo Booth/Discord etc., they come up with an error that my (internal) webcam cannot detected. The way I fix this is to reset the SMC , which does work but only for a few minutes, and then we are back to square one. I have tried sudo killall VDCAssistant and sudo killall VDCAssistant to no avail. I am running macOS Mojave, 10.14.3 on a mid-2012 MacBook Airenter image description here

Does anyone have any idea on how to fix this?

  • External webcam? Make & model? Internal webcam? What version of macOS? – IconDaemon Mar 12 at 18:00
  • 1
    See my newly edited post – John Mar 12 at 18:17
1

Try this: quit all apps attempting to use the camera, Finder -> Utilities -> Terminal (you'll likely be asked for your password, this is normal):

sudo killall VDCAssistant
sudo killall AppleCameraAssistant

…and reopen a camera app. I had an old MacBook Pro with a twitchy camera, and this solved it.

  • I've tried this – John Mar 13 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .