2

Things I have tried:

  • sudo killall VDCAssistant
  • sudo killall AppleCameraAssistant (shows no matching processes found)
  • Reset SMC
  • Reset NVRAM
  • Ran hardware test (shows no issues)

A few additional things to note: the camera´s green light stays on until I quite FaceTime or any other app that uses the camera (e.g. Photo Booth). Camera shows up fine under system report. The machine has never been opened.

Machine is a MacBook Air 2012 running High Sierra (latest version).

Finally, note that this may have started when I changed the system's language.

  • did you install any app recently ? – Ruskes Dec 18 '18 at 0:17
  • Try to start it manually here click on it /Library/CoreMediaIO/Plug-Ins/DAL/AppleCamera.plugin/Contents/Resources/AppleCameraAssistant – Ruskes Dec 18 '18 at 0:40
  • One thing I forgot to add: this may have all started when I changed the system's language. I used root access to make some modifications and I think this started shortly after that. – user314352 Dec 18 '18 at 2:01
  • @Buscar웃 I can get to /Library/CoreMediaIO/Plug-Ins/DAL/AppleCamera.plugin and launch it in bash. I don't see /Contents/Resources/AppleCameraAssistant – user314352 Dec 18 '18 at 2:04
  • ....hmm, you might be a candidate for system restore, still less intrusive the trying to replace hardware. – Ruskes Dec 18 '18 at 4:01
2

Test it using a new account (create one) or (after making a backup) on a fresh install. If that doesn’t work, the camera is defective. The USB interface and power indicator can still work with a broken video module, so the green light does not always indicate a working camera.

| improve this answer | |
0

The camera has failed.

It's not an expensive part, but you have to disassemble the entire LCD display assembly to remove it. Since the assembly is glued together, it makes replacing this part extremely difficult.

Therefore, you have two options:

  • replace the entire display assembly
  • get a USB web cam

(IMO) given the age of this laptop and the expense and difficultly of the repair, I would go with the second option.

| improve this answer | |
  • Thanks. This started when I changed the system's language, which is why I think this may be software related. – user314352 Dec 18 '18 at 19:09
  • @user314352 - It's highly unlikely that it's related to anything language related, but it would be good to see exactly what commands you issued. Booting in Safe Mode would address that issue. – Allan Dec 18 '18 at 20:50
0

Alert: "No Video / FaceTime has not received any video from the connected camera. Restarting your computer may fix this issue."

Google Meet: "Camera Failed"

I spent hours debugging this on my MacBook Pro (Retina, 13-inch, Early 2015) running Catalina. The camera did not work in any app.

I tried restarting, zapping PRAM, resetting SMC. In System Preferences, I checked permissions in Security & Privacy > Privacy > Camera.

In About This Mac > System Report…, the camera shows up correctly in Hardware: Camera.

I discovered that the camera did work in another user account, so it was not a hardware problem.

Long story short, I figured out that Screen Time > Content & Privacy Restrictions were inadvertently turned on, with Apps > Allow: Camera being disabled. I had turned on restrictions on an old iPhone; these settings are apparently shared across devices for the same iCloud account.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .