0

I updated to Mojave 10.14.3 last weekend at home. When I brought my MacBook Pro into the office Monday morning it showed it was connected to my office network, but there was no connection. I restarted the MacBook and it connected flawlessly. When I brought it home that night it said it was connected to my home network but it wasn't. Restarted and connected fine. Four days later it's still doing this every time I switch networks. Not a huge deal, but kind of a pain. Any suggestions?

  • When it's in its "connected but not really" state, does the Network System Preferences page show anything awry. When everything is good it should say something like "Connected - Wi-Fi is connected to <network name> and has the IP address <ip address>.", with a green dot in the sidebar list. – Ezekiel Elin Feb 21 at 17:28
  • Use Locations. The linked answer specifically address proxy settings, but it applies here as well. – Allan Feb 21 at 20:07
  • @EzekielElin yeah the preference page shows the green dot and says wifi is connected. – user783154 Feb 21 at 21:03
  • @Allan I'll try defining two different locations and see if that works. Thanks to you both. – user783154 Feb 21 at 21:04
  • I'm still experiencing this problem. I tried creating separate locations for home and office. Still having to restart the macbook every time a come into the office for it to actually connect, and about half the time I try to connect at home. Switching the location does not help. Any other ideas out there? – user783154 Apr 1 at 16:41
1

You can try to remove the network interface in "System Preferences > Network", select the network that isn't working, then press the "-" button.

enter image description here

And then add it back again by pressing the "+" and selecting "Wi-Fi" and naming it "Wi-Fi".

0

I have the very same problem however it is not a WiFi problem at all as my WiFi was fine. Talked to 3 Apple support advisors before they connected me with a senior advisor. The problem was that when I upgraded to Mojave I somehow Encrypted the OS which can easily happen. Seems the Encrypted version affects BlueTooth, WiFi which interferes with internert access. The solution was to do a back-up in Time Machine, then totally wipe (erase) your hard drive then reinstall Mojave (no Encryption)---And when you get to the option to transfer files, skip it and let it load. Then test your WiFi internet then restore any files. Worked perfectly for me. Most of the 1st level support people do not know about this issue.

  • Hello, and welcome to Apple Stack Exchange! Your answer isn't very clear, and could use some more formatting/details. By encrypted, did you happen to mean Firevault? Firevault does not limit wifi usage, and can be disabled without erasing macOS, so currently your answer doesn't make much sense. Please consider editing it. – Sam Jun 3 at 17:26
  • It seems that apple support does not agree with your assumption. According to them there is a problem, as I described, with Mojave. I'm sorry if this doesn't make sense to you, I was just trying to help. Feel free to take down my post. – Jim K Jun 5 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .