0

I have two WiFi networks: one at home and one in my office. Both are basically quite similar – same connection provider, same connection speed, same modem, same router – the only difference is that at home we use an AirPort Extreme station to broadcast the WiFi signal.

My MacBook Air (1.85 GHz Intel Core 2 Duo, OS X 10.7.5) does automatically recognize and log in to the AirPort Extreme powered home hotspot – but it won't auto-login to the office hotspot even though it does remember the network and lists it in the Network Preference.

Is there a way to 'teach' my MacBook Air to auto-login to 'whatever' WiFi network I want? Or does that only work with Airport Extreme powered hotspots? Or does it have anything to do with the Airport Extreme anyways? Thank you for any suggestions / pointers…!

  • what is the order of your networks in the pref? It will use that list and log in to the first on it, then in to the second and so on. – Ruskes Apr 15 '15 at 21:51
  • well – the home network actually is #1 and the office network #2 – but does that mean I can only auto-login to one network? – tillinberlin Apr 15 '15 at 21:55
  • when it looses the connection to the #1, it will tr to connect to #2, so unless your work and home are in the same WiFi area it should work. – Ruskes Apr 15 '15 at 21:59
  • Known networks are joined automatically (assuming that the password hasn't changed). There must be something else going on. – tubedogg Apr 15 '15 at 22:00
  • There's a 15 minute walk between both networks – never saw both networks at the same time. And passwords are saved – but the ffice network I always have to choose manually. This isn't a big issue – it's just bothering me – especially since I expected things to work as Buscar웃 and tubedogg dexcribe in their comments. strangeness. – tillinberlin Apr 15 '15 at 23:15
1

You can rule out your laptop for being the problem by resetting wifi configurations. Do Step 1, it's relatively safe.

http://osxdaily.com/2014/10/25/fix-wi-fi-problems-os-x-yosemite/

0

Found the actual problem and the solution for it: the network preferences still remembered the office network as a WEP connection. This has however changed some time ago since I switched to more secure WPA2 encoding.

I made the prefs forget the network and re-added it – now the security prefs correspond to the actual setting and the computer does automatically connect to the network. ALl fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .