0

With Android 5.0 wifi hotspot no longer disables on inactivity. So I often stuck with a problem: I work at park with my macbook connected to android phone wifi, after some time a close macbook and go home, I open macbook - and it reconnects to phone wifi as "last used", not to my home network. Each time i forgot to disable hotspot on my phone I get huge bills for mobile internet :(. Is it any way to force macbook to connect "best" wifi after sleep, not the "last used one"?

"Don't remember networks" and "don't save passwords" doesn't help - it still connects to last wifi network used.

Where is no way I know to make android wifi turn off after inactivity, such option was removed in Android 5.0

I'm using Macbook 12" with latest OSX 10.11

  • 1
    Unfortunately in your case one of the concepts needed to determine your "best" connection is the concept of metered vs unmetered wifi. (Your android hotspot is just wifi to your Mac.). I've sent Apple feedback with every major version suggesting they add "metered" vs "unmetered" as a wifi setting with no updates downloaded on metered wifi. – Tyson Oct 6 '15 at 10:10
  • @Tyson They have wifi order in settings, so all I need to do is somehow force this order to be used after waking from sleep. Right now macbook ignores order and connects to "last used" wifi if available. This makes sense in terms of connection speed, but not in my bills :) – grigoryvp Oct 7 '15 at 5:17
1

Go into System Preferences-> Network. Select Wi-Fi and click "Advanced" change the order of preferred networks so that your home network is listed before your Android hotspot's.

  • Not working: macbook automatically reconnects to last network it was connected to, which is my mobile phone hotspot – grigoryvp Oct 7 '15 at 5:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .