0

My colleague and I both use Macbook Pros on the latest Mac OS.

He exports CSV files from MS Excel for Mac and sends them to me, but when I receive them I open them in a text editor and there are blank lines on every other line.

Weirdly though, when he opens the same file on his machine in the same text editor, he does not see blank lines. Which makes me wonder if this is a setting on his machine.

I know Windows and Mac treat line endings differently, but we are both on a Mac. And Sublime should be the same on both machines.

When I upload them to our linux server, linux agrees with me (our scripts see blank lines in the CSVs and have to be ignored).

He is creating CSVs using the UTF-8 format.

1

If you look at your file with od -cx you will notice that every lines is terminated by the sequence: 0x0d 0x0a i.e. a carriage return followed by a newline.

There is most probably a difference between your 2 Sublime Text preferences in their way to manage the carriage return.

The next best explanation is a difference in extension you gave on your 2 text files which set Sublime Text in a different way to manage the character carriage return == 0x0d (coming from the last century type writers).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .