6

I've been experiencing a very weird clipboard behaviour on my mac.

This is my OS

enter image description here

I'm a developer and every now and then I need to copy paste code, text or even files around.

What I've been experiencing lately is that the clipboard is not being shared among applications.

For example I can't copy a url from Chrome and paste it into Safari. It doesn't give me any error, it just wont paste anything.

For example I just selected this page URL, but on the clipboard I see the URL dropbox added to my clipboard.

enter image description here

Another strange issue is that I use Sublime Text on a day to day basis, and sometimes if I need to copy and paste code somewhere else, it either wont paste anything at all or adds sometimes 10 new lines between each line of what I copied and sometimes 1000s of new lines in between. Which is very annoying.

I've tried restarting the clipboard from the terminal and from Activity Monitor and still the same issue.

Sometimes when I quit and reopen sublime, the issue in sublime itself gets fixed but for a short period of time. It then comes back.

I also use Alfred 2 for workflows and shortcuts which has a clipboard history, but when it starts happening it wont copy into it's clipboard either.

Sometimes copying and pasting works just with the mouse and sometimes not even with it.

I've also tried repairing permissions, run Onyx and repair everything.

UPDATE I recently tried rebooting in Recovery mode to repair permissions as well as clearing the NVRAM but I'm still experiencing the same thing.

So far the only solution I have found is a reboot, which makes it work for a while.

Any clues?

  • I've seen it too - no fix that I've found. I'm basically chalking it up to a bug for now...just my 2-cents. – willWorkForCookies Nov 12 '15 at 20:53
  • I've rebooted and cleared the PRAM and it seems that it solved the issue. Still need to do some more testing to make sure, but so far so good. – Federico Giust Nov 12 '15 at 23:10
  • Three years later, I am noticing similar strange behavior, but not often. I hope someone has reported the bug. – WGroleau Aug 28 '18 at 18:54
3

HO! Just moments ago, four different copies appeared in various software on my macbook

  • AAA: Clipboard
  • BBB: SecureCRT iTerm Evernote
  • CCC: Chrome
  • DDD: Sublime

I have two solutions.

  1. Open the Terminal application(found in /Applications/Utilities/),Type the command killall pboard , Hit Return(Recommend);
  2. copy different text and paste it;

But I still don't know why....

macOS 10.13.6 (17G65)

  • Do you have any password manager that might try to clear and restore clipboard contents on a timer to protect copied pass phrases or passwords? – bmike Aug 28 '18 at 15:47
  • no password manager – Stephenmjm Feb 25 at 11:16
  • 1
    My third solution is, add a workflow run scrip 'killall pboard' in Alfred. So I can run 'killall pboard' in 2 seconds when it occurs. – Stephenmjm Feb 25 at 11:21
1

Had this issue after installing a system update. When I rebooted it turned out I had only partially completed the installation. My machine went through a couple minutes of automated update screens on startup and then then the issue seemed to be fixed.

Have you tried turning it off and on again?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .