1

I have a 2015 MacBook Air 128GB with Sierra Recent purchase as new from Apple, still under warranty). A couple of months ago I was looking at the SSD using DiskUtility and saw that the SSD seemed to be a lot more than 128GB, it looked like it was 256GB. 128GB was available to me and the rest was a CoreStorage partition. (Give or take a few GB for the Recovery partition.) So I thought that if I could remove the CS partition, I would have 256GB available to me, not 128GB.

A couple of manoths later, I finally got time to try it. Much to my surprise, there is no CS partition anymore. HD Utility doesn't show one, so I tried Terminal and still no CS partition, whereas previously there was a CoreStorage partition shown. And the SSD is only 128GB.

So where did the CS partition go?

  • You didn't install High Sierra at any point? If so, that might have removed core storage container and converted it to an APFS container. Some other tools can remove all core storage as well and leave you with a traditional HFS+ on disk structure as opposed to HFS+ embedded in core storage. – bmike Oct 16 '17 at 1:58
  • I haven't installed HighSierra yet, but I did have my OS reinstalled a few months ago (at a Genius Bar) to try to fix a different problem. However, I don't see why this would have eliminated the CS partition. And anyway, if it did, where did those CS GB go? – K Prosser Oct 16 '17 at 18:51
1

It is possible that you misinterpreted what you saw. The diskutil list command in Terminal, for example, would show you both the 128GB physical disk, as well as the 128GB CoreStorage logical volume. These are listed separately, but are in fact the same storage.

Running disktuil cs list in Terminal will confirm if you have a CoreStorage volume or not. To my knowledge, it's not likely that a CoreStorage volume would revert itself. One possible cause that I can think of would be a reinstall of macOS.

  • How can they be the same storage if they are different partitions? The MacOS part is 120GB, the restore part if 5GB (I think) and the CoreStorage was 100GB or so. The diskutil cs list command says I now have no CoreStorage partition. But I had one, or so I thought. Maybe I hallucinated it? I sure wish I had kept screenshots of that, but who would have thought it would disappear? – K Prosser Oct 16 '17 at 18:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .