I converted a partition to a CoreStorage volume using this command:

sudo diskutil cs convert disk0s2 -passphrase test123

Now when I run `diskutil cs list' the output shows that I still only have a Logical Volume Group and a Physical Volume attached to it (from what I gather, I should have a Logical Volume Family and a Logical Volume as well). The status of the LVG is 'Offline' and the status of the PV is 'Checking'. It has been this way for over 10 hours on a 128GB SSD.

To me it seems this status indicates some kind of intermediary status, as if the conversion/encryption has not completed yet, is that assumption correct?

Is it safe to shut down the machine in this state?

In Disk Utility.app the disk name is shown in red! I can run the Verify Disk command and the output seems ok (ends with 'The volume {UUID of the LVG} appears to be OK' and 'The partition map appears to be OK').

But in the output of Verify Disk I see mention of a logical volume ('Logical Volume Group contains 1 Logical Volume'), which the output of diskutil cs list does not show. And following that, I see mention of two UUID's to which diskutil cs info {UUID} responds '{UUID} is not a CoreStorage UUID'.

To me this seems inconsistent, and I'd like to resolve this.


I tried to manually create a Logical Volume (since it seems to be missing form the diskutil cs list output) using diskutil cs createVolume {LVGUUID} jhfs+ "Macintosh HD" 100% which resulted in:

Error: -69780: Unable to create a new CoreStorage Logical Volume

2 Answers 2


I had the same problem after converting a disk. There was a message displayed by diskutil cs convert:

Couldn't unmount disk0s4; converted volume won't appear until it's unmounted

I solved the problem by unmounting the disk and repairing it :

diskutil unmount force disk0s4
diskutil repairVolume disk0s4
  • I encountered the same issue. Julien Eyriés - your answer worked well for me. I tip my hat.
    – user65847
    Commented Dec 27, 2013 at 21:41

I attached my Time Machine drive to make a backup and then rebooted my computer. After reboot I was presented with the "Disk Password" by EFI ("test123" worked as expected) and then I had to log in to OS X with my account password.

diskutil cs list now shows the normal tree for a CoreStorage pool with one volume, and status is 'Online'. In System Preferences FileVault is encrypting with 18 minutes left. I am not sure if waiting another 18 minutes without rebooting would have updated the output of diskutil cs list or that my reboot triggered the updated output (and maybe the encryption as well).

TL;DR After converting it seems safe to reboot the machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .