1

I purchased a refurbished MacBook Pro (MPB) to replace a previous one of almost the same model. (Lest anyone wonder why such a foolish thing, I bought the old one used for cheap and it had signs of being dropped. The new one looks nicer and has a one-year warranty.)

In getting ready to migrate, I wanted to do one last backup. It was then that I noticed Time Machine says the last backup was at the end of the previous year (two weeks ago). I am fairly certain I had the drive connected several times during those two weeks, and even clicked "Backup Now" more than once. There were no "unable to back up" notifications.

When I looked at TM preferences, the "Preparing to backup" progress bar gets to the end (or almost—it's hard for my eyes to tell whether the "last pixel" is still not blue). But it stays there until I order it to cancel. (Five minutes/sixty minutes according to my level of patience)

fsck_hfs found nothing wrong with the drive.

I found at least one web page that said this happens sometimes and a supposedly simple fix is to trash the *-in-progress backup, reboot, and try again. Not only did that not help, SIP prevents emptying the trash.

Any explanation and/or solution?

I would like to "inherit" the backup, but if it's corrupt, I would wipe the disk instead and start over.

  • Do you have both MacBook Pros on hand? If so, my suggestion is to skip Time Machine on the old one and use migration assistant for a few reasons. 1) New computer = new hardware information (specifically relating to the disk). Using migration assistant makes sure that all of your files and applications, including licenses, transfer smoothly. 2) Using migration assistant is non-destructive. i.e.: you won't lose the data on the original MBP as you transfer to the new one. 3) It's easy! This way you don't have to deal with the problem of the Time Machine; just start a new backup on your new MBP. – NoahL Jan 15 '17 at 3:08
  • I did say I am going to migrate. But I also said I also want a full backup of the latest changes, and I do NOT want to start a new backup sequence. – WGroleau Jan 15 '17 at 3:14
  • Oops! My bad. Then you should move the inProgress folder to the trash, disable SIP, empty the trash, reenable SIP, and then try backing up again. – NoahL Jan 15 '17 at 3:15
  • The in-progress was moved to the trash twice, but after reboot (like the dozen or so reboots that have happened this year), backup still doesn't work. SIP is only an inconvenience with the trash. When the package is not in the backup directory, TM is able to create a new one, but it never gets out of the "preparing backup" state. – WGroleau Jan 15 '17 at 6:16
1

I would go with the general thrust of the suggestion of NoahL in comments (i.e. move the inProgress folder to the trash, disable SIP, empty the trash, reenable SIP, and then try backing up again).

However, if you do not know how to disable/enable SIP, you can follow these steps:

  1. Start your MBP
  2. Immediately hold down the commandR keys to boot into recovery
  3. Click the Utilities menu and select Terminal
  4. Type csrutil disable and press return
  5. Close the Terminal app
  6. Select Restart.... from the  menu

Once you've rebooted, empty the Trash (assuming you've already placed the inProgress folder in the Trash). Once emptied, shutdown your MBP and follow the above steps again, except that at Step 4 use csrutil enable instead of csrutil disable.

  • I know how to disable SIP, but the fact that it is "stuck" in the trash is irrelevant to the fact that no backup has completed in two weeks. I was just pointing out that reboot did NOT fix it. By the way, in the current version you can re-enable SIP without rebooting. – WGroleau Jan 15 '17 at 6:04
  • Your assumption that the inProgress folder being stuck in Trash is irrelevant to the fact that there's been no backup in two weeks may be incorrect. While it probably doesn't explain why the backup failed the first time, it could in fact explain why it's failed for all subsequent backups. The only way to be sure is to empty the Trash and let TM try to do its thing. Also, thanks for the tip re being able to now re-enable SIP without rebooting. :) – Monomeeth Jan 15 '17 at 6:12
  • They have only been in the trash for less than a day. IIRC, there was not one a few days ago when I looked in the backup folder. However, for the sake of completeness, when I have time, I'll get rid of them completely and if it appears to not be fixed, I'll let it keep going all night and check again. Unless, of course, someone comes up with an explanation or a fix. – WGroleau Jan 15 '17 at 6:24
  • My apologies for not being a little clearer. It's not so much that the inProgress folder is in the Trash, it's the fact that it exists at all, anywhere, that could be causing TM problems. Totally removing any and all inProgress folders eliminates that as a possibility for the issue. If it doesn't resolve it, then we investigate other possible causes, one by one. If necessary the community is here to help continue troubleshooting. :) As for TM's original failure, that could be due to any number of reasons, a random power surge even. – Monomeeth Jan 15 '17 at 7:39
  • Like I said, I intend to try that when I have more time (plane to catch). But as I said, I am pretty sure there was NOT one of those two weeks ago when backups stopped. Or one week ago when they still were not working. – WGroleau Jan 15 '17 at 13:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .