1

EDIT: It appears this may not in fact be a Synology issue, as I'm now experiencing the same behaviour trying to run a Time Machine backup to a newly-formatted local USB drive.

I just bought a Synology DS220j mostly to replace my dying Airport Extreme, which I was using for Time Machine backups from my MacBook Pro (10.14.6). So far, I've been unable to complete a single TM backup to the Synology.

The main problem is that the backup always stops after backing up only a few tens or hundreds of megabytes, usually with no errors in the Time Machine preferences pane or in the Console, but very occasionally with a "Could not complete backup" notification.

I've tried doing a new backup from scratch, and I've tried seeding a backup from my last good sparsebundle file on my previous backup disk (after fsck-ing it for errors). I've tried over SMB, and I've tried over AFP (which I've now turned off again, as I know it's deprecated and generally doesn't play too well with Synology).

Currently, I'm running a cron job on my Mac that runs 'tmutil startbackup' every 5 minutes. This is my second attempt at that—the first time, it nearly got to the end after a couple of days, but then the "amount remaining to backup" just kept increasing faster than it was backing up, so that backup never finished either. (I don't think that's a Synology problem, though—seems to be a known issue when using TM with a NAS, though I don't know how to solve that either.)

Can anyone suggest anything to make this less painful, and preferably, Just Work?

9
  • You did enable the TimeMachine functionality on the Synology I assume?
    – nohillside
    Jan 23 at 15:00
  • Yes, Bonjour Time Machine broadcast is turned on (SMB only, currently), and the folder in which I want to keep my TM backups is correctly selected.
    – calum_b
    Jan 23 at 15:51
  • Did you set a disk quota for your user on the NAS which would prevent a full backup?
    – nohillside
    Jan 23 at 16:00
  • I’m basically going to say, stop doing all the things you are. No seeds, no restrictions, just start with a clean minimal backup. Then after a week or month, you can add fancy steps or restrict if you think you need it.
    – bmike
    Jan 23 at 16:11
  • @nohillside The user has a quota of 1Gb (can't set the quota on the folder, on this NAS model), which should be more than enough for the first backup of my 512Gb MacBook Pro. I've considered disabling or increasing the quota to see if it makes a difference, haven't tried it yet.
    – calum_b
    Jan 23 at 17:11
1

New information has come to light. The Mac may need directory repair, significant space freed or just an erase install based on multiple clean Time Machine starts failing.


It’s hard to pick apart backup issues with such a custom setup.

I recommend you start with the “nurse” procedure at the bottom of my answer - working up to fsck and safe boot as appropriate. Exclude three folders and let a minimal backup complete. Consider throwing away the old backups and starting with a clean slate, no restrictions or fancy settings - let Time Machine think it can use the entire disk.

/Users
/Library
/System

If the interface asks to skip all system files, say yes. Once you have hourly backups going well. Remove things from the exclusion one by one and focus on disk corruption on the source if that’s where the backups hang.

Also, disable cron forcing things while stability is not present. Let the normal triggers work until you’re solid is my advice. Also, The Time Machine Mechanic and Backup Loupe are invaluable tools for me working on problematic Time Machine situations. Yours seems overly not easy, so something is causing you pain that hopefully can be identified and remedied.

16
  • Worth a try, thanks.
    – calum_b
    Jan 23 at 17:11
  • I hope you get it sorted in short order. Everything you’re doing is based on very reasonable planning and experience from what I can see, @calum_b - please post your fix and accept it - my answer is a process and guideline and not a definitive fix of a specific issue.
    – bmike
    Jan 23 at 17:44
  • Thanks. Interestingly, if I try to exclude everything from the TM backup bar one small root level folder, the estimated size still shows as 430Gb, and tinkering with the exclusion list never really changes that. Not sure if that's significant, or how to address it...
    – calum_b
    Jan 23 at 18:39
  • Have you tried restarting the Synology? I have seen with mine (a 414), that occasionally the user will get wedged and hold a session open, and after that the Mac can't complete a backup because the Synology has the sparsebundle locked. I have the 'Connected Users' widget on the desktop, and kill the user when I see it there. Note that "occasionally" is measured in months, I just had it happen (which makes me remember it) and before that it was June last year. Jan 23 at 18:44
  • Yes @calum_b , you have all the symptoms of a confused accounting of the source. Exclude everything and then let it rip... heck, you might try adding a USB direct attached drive so Time Machine can get a quick good backup and then reset the “calculations”.
    – bmike
    Jan 23 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .